Android: Failed to load SpiderMonkey library ""

ToDo demo app opens fine in Windows and macOS. But in Android after session is established to server and records loaded this error:

Business Rules Scripting is added in project wizard, i guess this has something to do with that?

Tryed to compile to iOS and get this error:

More challenges:

  1. When creating FMX app with DA wizard, in iOS Project/Options/Version Info all info.plist keys are missing.

  1. If i first make FMX project and add with DA wizard DM and LogOnForms to existing project, ClientDataModule and LogOnForm is missing from Project/Options/Forms.

Haven’t used Delhi for 15 years, so i don’t remember how to manually add forms there. But they are in project “Version info”:

Solved form showing problem, changed manually project “Version info” (can’t remember what it’s called):

And can open app without errors about missing if i don’t check in DA wizard support for Business Rules Scripting. So is it so that is some kind of java language library and it’s missing from Android/iOS?

My apologies for the delayed reply, but the best person to help with this is off today due to a local holiday; I’ll make sure someone will the back to you, tomorrow!


No hurry, i’am not going to do any mobile app for a while. Just started making desktop app where Android is going to add info from phone call log, and mobile is not going to be first priority for a while.

Must say that this DA is awesome, i been able to establish working middle tier cloud backend with just in few days without any previous experience :slight_smile:

1 Like


this file can be found at C:\Program Files (x86)\RemObjects Software\Data Abstract (Common)\Redist\Android\

Linux and iOS platforms weren’t supported.
We support only Windows, MacOS and Android platforms.
Required files can be found in C:\Program Files (x86)\RemObjects Software\Data Abstract (Common)\Redist folder

Thanks, logged as bugs://84260

Don’t know how to get this file to android phone. Found this topic about same question but link to instructions is broken.

Tried to search from net articles but didn’t find any. Can you provide some source where i can get instructions to get file to phone?

Ok, it’s no problem. Have noticed that with iPhones many things are not possible to accomplish because of Apples security policy, with Android life is easier.

Check the Deployment Manager and Deployment Manager - Adding files articles.

bugs://84260 got closed with status fixed.

1 Like