Bug: Can not publish webservice

(marc hoffman) #17

ok. with Legacy I assume it all works?

(Theo) #18

The button pre-build Events works.
But with legacy I have the old problem that it can not find the referenced namespaces back.

Edit: and when changing back, the problem stays.
Did not have this one for a week …

(joseasl) #19

Having problems here too. After changing to Legacy targets, the web application seems not to find the other assemblies that are not set as Legacy (this is a guess). It is strange as it doesn’t complain about an missing assembly, but about the classes in those assemblies.

(E46) Unknown identifier “Database”

Went back to RemObjects.Elements.Echoes.targets and it builds again, but it doesn’t publish.
Reinstalled .2309 and all works.

One other thing I noticed. Building with .2314 was a lot slower. I have reinstalled it to measure it.
With .2309 a rebuild of the project takes about 13 seconds. With .2314, about 56 seconds.

(joseasl) #20

@mh I forgot, trying to downgrade to .2309 from .2314 gives an error in the installer:

The Spanish part says, “Unable to create a file that already exists”
Uninstalling and installing again works.

On the other hand, looks like new project version names are coming, if needed :wink: “Sir Patrick Stewart to reprise Picard role in new Star Trek series. News comes at official Trek convention in Vegas; will be CBS All Access exclusive.”

(marc hoffman) #21


As for the other stuff — well 80683 is still open, to lets wait until that is actually fixed?

Yeah, probably expected. this used to be a file and its now a folder, and the old installer doesn’t know how to cope with that.

(Theo) #22

I will do that now - staying on 2309, that still uses MSBuild until it is fixed.

(joseasl) #23

I’ve just tried this and it works:

I’ve installed the latest build and replaced

C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\RemObjects Software\Elements\RemObjects.Elements.Echoes.targets
C:\Program Files (x86)\MSBuild\RemObjects Software\Elements\RemObjects.Elements.Echoes.targets

with a copy of RemObjects.Elements.Echoes.Legacy.targets

Referenced namespaces not recognized during compile
(Theo) #24

Yes, that is correct.

But I have several dll projects that are part of all my projects.
To be able to build a webservice, I have to set it to legacy. And all the dll’s in the same projects too.
But these dll’s are also part of other projects, and because I have to set them to legacy for a webservice, I have to set these other projects to legacy too, ending up in editing all my project files to legacy.

(joseasl) #25

No, you haven’t understood me.
I didn’t edit the project files, but I replaced the file itself in
C:\Program Files (x86)\MSBuild\RemObjects Software\Elements
C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild
So the compiler will still search for RemObjects.Elements.Echoes.targets, but the contents of that file will be the legacy targets.

(Theo) #26

I am going to try :smile:

(Theo) #27

YES !!! :smile:
It works !!!

Thank you very much!

back on 2313.

(joseasl) #28

@mh I think I see progress in this. Looks like it compiles almost everything. I’m still testing.
Just two things:

  • Seems to be a problem when referencing the new Visual C# project structure. In this case I was trying to reference this one, so it can be tested easily:

  • When I tried to publish, EBuild says
    Error () Build encountered more than 1000 errors or warnings. Further messages will be supressed.
    (Yes maybe there are a few warnings right now… :wink: ) But the problem that message is not a warning, but an error, and it stops the publishing process.

I’m gonna try without so much warnings and see if it works.

(marc hoffman) #29

Oops. Fixed.

can you elaborate?

(joseasl) #30

Test case
ReferenceVC.zip (41.6 KB)

(marc hoffman) #31

ok, but…

but what is the problem you’re reporting? I don’t like looking at test cases and having to guess whether the behavior I’m seeing is the one thats ostensibly being reported or not.

(joseasl) #32


Error () Project Reference '..\ClassLibrary2\ClassLibrary2.csproj' could not be resolved for target 'Echoes' (Echoes .NET anycpu). ReferenceVC C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\RemObjects Software\Elements\RemObjects.Elements.Echoes.targets 53

(RemObjects) #33

Thanks, logged as bugs://80800

(marc hoffman) #34


your Hint path is wrong:

    <ProjectReference Include="..\ClassLibrary1\ClassLibrary1.csproj">
    <ProjectReference Include="..\ClassLibrary2\ClassLibrary2.csproj">



should be


(RemObjects) #35

bugs://80800 got closed with status testcaseerr.

(joseasl) #36

Sorry, it seems I missed the notification for this.

That HintPath is not set by me, manually. I’ve just added the reference in VS with the add reference dialog.
They are all empty projects, just as VS creates them, nothing special.

I’ve just changed the HintPath and it builds, but if I remove the project references and re-add then in VS, the HintPath is wrong again, so it doesn’t build. So there is the bug then?