Can not start application from within VS2022 after upgrade

We recently tried to upgrade to the latest April release of Oxygene and after fixing some compiler errors (weird overloads no longer being found on framework types)
We now get this error in VS2022:

Microsoft Visual Studio

Error debugging project: No Executable or App Bundle was specified.


It should be noted that the projects still use the legacy target, but we need so because the new target is not usable for us, we have a huge solution with many C# projects in. also we need to have the post build scripts working.

Any ideas how to fix this?

You think these were legitimate errors or that there was something wrong with the compiler?

Curious. does this happen only for Legacy, or for a new .NET project created without legacy, too? Does it happen for all Legacy projects, for you?

The compiler issues I think were correct, so nothing to fix there.

I tried the not starting of the app and it works on any project:

  • Create a new WPF Dotnet 4.8 project.
  • Run
  • It will run fine
  • Unload the project and edit the project file: add the .legacy into the imports
  • reload
  • Compile
  • Run
    The app will not run and give the same error as mentioned in the first post.

Logged as bugs://E26569.

bugs://E26569 was closed as fixed.