Cannot create new connection because in manual or distributed transaction mode

Changing database engine from Postgres to MS SQL Server find this problem at server side

Cannot create new connection because in manual or distributed transaction mode

Solution according to UniDAC is change connection parameters as pointed here

https://forums.devart.com/viewtopic.php?t=21813

SQLConnection1.VendorLib := ‘sqlncli.dll’;
SQLConnection1.Params.Values[‘Custom String’] := ‘MultipleActiveResultSets=True’;
SQLConnection1.Open;
TD.TransactionID := 1;
TD.IsolationLevel := xilREADCOMMITTED;
SQLConnection1.StartTransaction(TD);
ClientDataSet1.Open;

How to setup the string connection to accomplish that?

Best regards.

Hi,

You can set UniDAC options via connection sting only these values:

  • Options.<Param>=<Value>
  • SpecificOptions.<Param>=<Value>
  • QuerySpecificOptions.<Param>=<Value>

so try to specify MultipleActiveResultSets in SpecificOptions like

SpecificOptions.MultipleActiveResultSets=True;

pls read https://www.devart.com/unidac/docs/using-sqlserver.htm for details what properties you can specify in SpecificOptions too.