Cannot run sample project Delphi WPF


I’m trying to build a Delphi XE7 Host application and load a .NET visual plugin but not even the Hydra samples are working.
I’ve compiled the vistual plugin project using Visual Studio 2008 and the host project with Delphi XE7.
When I run it, on the HYModuleManager.LoadModule line, I get an error saying:

“At least one type in the assembly cannot be loaded.”

I was able to load a visual plugin compiled in Delphi but not a .NET assembly.

What am I doing wrong?


I can’t reproduce this case.
Can you test this sample with my Visualizer.dll that was compiled with VS2008 ? (6.8 KB)

I get the same error message with your DLL too.

The option “Buid with Hydra Core Packages” is set and I copied RemObjects.Hydra.dll into the applications directory

What now?.

looks like you haven’t copied RemObjects.Hydra.WPF.dll assembly

try the whole sample: (416.0 KB)


That was it!
I don’t have this DLL on my computer… Is it installed only if I have a .net development platform installed on my computer?
I also did not found any reference to this DLL, only the other one I already copied.

Thanks a lot!

yes, these dlls are installed only if VS2008+ is detected.