Can't connect to Mysql using .net driver with Fire/Silver

Should I need to install anything more?

I am not trying to debug into Trim. I just asked to go into Connect function at my DLL from my program.
After I used Go Into I get this error before I go to my first line of code.

Well, its the example you showed. again. If your leg hurts show me your leg, not your arm. Else can’t help you.

This code is in my program:

At line at c.Connect I try to go into Connect but it is inside my DLL. This is the code of Connect:

Before this code appear to me, I got the error.

I just clicked to Go Into my code once, then I should be at first line of connect that is the IF but instead of it I get the error.

Could I explain better?

probably, like:

WHAT error?

What error? This screen:

Remember that I DON’T tried to debug TRIM function just my function Connect.

AGAIN. you’re debugging into Trim, not Connect!!! It’s Trim that Fire cannot show you source for!

No, I am not. Is that what I am trying to say! I am not!

Well, it’s what the screenshot is showing.

I just clicked once at my program to go to to Connect function at my DLL.

Exactly! Fire shows it BEFORE I can stay there to debug anything.

Fire shows it because my function have a call to Trim but I never tried to debug the Trim function

I hope you have understood what I am trying to say because I don’t know how explain it in another way :slight_smile:

Not sure what to tell you. The screenshot shows you trying to see Source for String.Trim() with you don’t have.

Are yo sure your .dll is build with .MDB debug symbols turned on, and do you have a .dll.mdb file next to it?

Fire is trying to debug it by himself without I ask it.
I just asked to debug my own function Connect and before this function is showed to me to I can debug I got the error like IF I had tried to debug the Trim function - what I didn’t.
I don’t know if Fire is doing it because Trim is in the first line of my function Connect but Fire should stop at the first line without do nothing until I click to Go Into or Go Over. Just enter in the function inside my DLL to let me decide what to do. Instead of it, Fire is debugging the first line without I command it.

In others words, the compiler (Fire) is doing a task WITHOUT I ask.
Because Fire is debugging inside my function BEFORE the function code be showed to me and BEFORE I can do anything. And I only had commanded to Go Into my function, not to debug any line there.

A video showing my point:

i ask for the third time: are you sure your dll is built with debug info?

What debug info?

The one needed for debugging.