Compiling, debugging or creating new projects in VS doesn't work with latest Elements (.2735)

After installing latest elements (.2735), i can’t compile or debug my projects with Visual Studio 17.2.


The ContextMenuItems “Build” and “Rebuild” are not there in .2735


Invoking “Build” via MainMenu or Keyboard-Shortcut starts “something” (Build started…), but nothing really happens and there seem to be no end and you have to kill VS via Task-Manager.

Also creating new (Elements-)projects from template fails with a “file not found error” - but i can’t say what is missing.


Snippet from ActivityLog.xml:

    <time>2022/05/17 06:19:03.809</time>
    <source>Template provider aggregator</source>
    <description>System.IO.FileNotFoundException: Das System kann die angegebene Datei nicht finden. (Exception from HRESULT: 0x80070002)&#x000D;&#x000A;   at Microsoft.VisualStudio.CommonIDE.Solutions.Interop.IVsNativeEnvironmentInternal.WizLoadAndRunFile(String pwszWizard, String pwszDestination, Boolean bCloseSolution, Boolean bRunSilent, Array psaCustomParams, String pwszFrameworkVersion)&#x000D;&#x000A;   at Microsoft.VisualStudio.CommonIDE.Solutions.Dte.DteSolution.&lt;&gt;c__DisplayClass256_0.&lt;AddFromTemplateEx&gt;b__0()&#x000D;&#x000A;   at Microsoft.VisualStudio.CommonIDE.Solutions.HResultExtensions.ExToHr(Action action)&#x000D;&#x000A;   at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)&#x000D;&#x000A;   at Microsoft.VisualStudio.CommonIDE.Solutions.Dte.DteSolution.&lt;&gt;c__DisplayClass25_0.&lt;EnvDTE100.Solution4.AddFromTemplateEx&gt;b__0()&#x000D;&#x000A;   at Microsoft.VisualStudio.NewProjectDialog.LegacyVsTemplateProvider.GetInstantiationResult(CreateProjectResult result)&#x000D;&#x000A;   at Microsoft.VisualStudio.NewProjectDialog.LegacyProjectTemplateProvider.&lt;InstantiateTemplateAsync&gt;d__7.MoveNext()&#x000D;&#x000A;--- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A;   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()&#x000D;&#x000A;   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)&#x000D;&#x000A;   at Microsoft.VisualStudio.TemplateProviders.TemplateProviderSupport.ExceptionLoggingTemplateProviderDecorator.&lt;InstantiateTemplateAsync&gt;d__9.MoveNext()</description>

Maybe this is a hint:

    <time>2022/05/17 06:18:42.592</time>
    <description>Still unable to load MEF component DLL: Die Datei oder Assembly &quot;Microsoft.VisualStudio.ReferenceManager.Contracts, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a&quot; oder eine Abh&#x00E4;ngigkeit davon wurde nicht gefunden. Das System kann die angegebene Datei nicht finden.</description>

On my side, I only have problems with old ASP.NET web site: Debugging an old ASP.NET web site
I think the problem is related to VS 17.2.

Hello Patrick,

i downgraded Elements to version .2731 on VS 17.2. after that and everything seem to work “as expected” then.
As i don’t have ASP.NET projects i can’t say anything about that.

does this persist with 2739?

Had to try out, but yes, it does.

Meanwhile VS is updated to 17.2.1 but the problem is all the same.

can you remove: C:\Users\username\AppData\Local\Microsoft\VisualStudio\17.0_… ? and start vs again? That often helps cleaning up a broken VS (the build works fine for viktoria and myself).

Unfortunately, that didn’t help.

I think we have found what the problem was and fixed it. We uploaded a new build with the fix on your personal downloads. Could you please try it and let us know if it fixes your issue.
Best regards.


sorry to say that - but that didn’t fix it, too :frowning:

Does the problem appears for some newly created project, e.g. for newly created Oxygene Console app? Or a particular one?
Can I teamview on your machine tomorrow at any time that suits you? I cannot reproduce the issue here but it looks like the Editor extension was cached somehow and uses an old dll.

I can’t create new projects (any Elements-language and project-type, as far as i know), if i try i get a file not found error from VS.
Some files are created despite it, but some things don’t seem to be valid (sln-File?) (32.5 KB)

And the cache is cleared, every time i install .2731 and dirty for every other tested version?

TeamViewer: Just send me a message tommorow and i will send you my id.

1 Like

Hello. I am ready for a teamview when you have time. You can send me your id via private messages.

Logged as bugs://E25906.

bugs://E25906 was closed as fixed.

The changelog says that the error(s) should have been fixed with version .2741 - unfortunately I have to say that I still have the same problems after I installed the new version. :face_holding_back_tears:

Do you still have the same error with the same dll? Or maybe it cannot find another dll?

This exception is thrown if i attach VS to VS like you did recently.

Exception thrown: 'System.IO.FileNotFoundException' in RemObjects.Elements.VisualStudio.Project.17.dll
Could not load file or assembly 'Microsoft.VisualStudio.Web.Application, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. Das System kann die angegebene Datei nicht finden.

The same exception is thrown when I start “debugging” or want to create a new project.

Does this .dll exist?


if i change my VS installation and add the “ASP.NET and web development”-Workload, everything seem to work as expected in VS with .2741.

Since I don’t do web development, this package was not (never) installed before. Actually I would prefer it to stay that way. :wink:


Because of that i added the ASP.NET-Workload (previous post).

And now it exists…