Currently TROCodegen4 generates
_Intf.pas source code that contains a lot of ifdef’s.
Please, could you add a way to control what switches should be turned ON?
I mean that TROCodegen could have something like this
TROCodegen.DelphiSuppressSwitches: Boolean; TROCodegen.DelphiGenerateSwitches: TROCodegenDelphiGenerateSwitches; TROCodegenDelphiGenerateSwitches = set of (dgsDelphiXE2Up, ...);
To make source code more readable it would be great to control at least the following switches:
The new approach with
DelphiSuppressSwitches:= False (by default) won’t influence the existing clients, which use the switches.