Elements with Visual Studio 2017 integration - no items in New Project


(prereq.: Visual Studio 2017 Enterprise, Windows 10 Pro English)

I have installed Elements 10 trial and specified VS 2017 integration in the installer.

RemObjects extensions are present in the list of extensions (main menu -> Tools -> Extensions and Updates…). However, when invoking the “New Project…” dialog box, there are no RemObjects’ templates listed.

I tried to disable and enable the corresponding extension, but no visible difference.

Is there anything I can look at / for to address this problem?

When you search for, say “Oxygene” in the New Project dialog, do you get no hits? What happens if you create a new project in Water and then open it in Visual Studio — does to open and work fine?

Search result - “nothing found”.

Open in VS - "Unsupported. This version of Visual Studio is unable to open the following projects. The project types may not be installed or this version of Visual Studio may not support them. "

So far it looks like the extensions are loaded, but are not initialized - there are no RemObjects-related items in Tools->Options dialog either. The question is how to approach the problem in the first place - what registry settings or files to check, given that I already tried reinstalling Elements (without uninstalling it, I admit) and disabling/enabling the extension.

Ok, so t looks like Elements isn’t installed into VS2017 at all. I’ll have to let my colleague help yo with that tomorrow, as this is outside of my wheelhouse. In the mean time, is using Water a viable option?

Thank you. For tests, Water will be sufficient. For actual work, we use Visual Studio extensively, and it’s not very comfortable to use different keyboard shortcuts for everything (I even looked for keyboard customization option in Water but it doesn’t seem to have one). I remember that you prefer macOS, but for us, Windows is the main platform.

Thanks, logged as bugs://83784

bugs://83784 got closed with status fixed.