Exception occurred creating type 'RemObjects.Hydra.VisualPlugin

visual-studio

(Jeffrey Lange) #1

I recently upgraded my laptop to Win10 and installed our licensed version of Hydra for our project. We are using version 5.0.91.1169.

Now, when it goes to load the project in Visual Studio I get the following error:

Error 104 Exception occurred creating type 'RemObjects.Hydra.VisualPlugin, RemObjects.Hydra, Version=5.0.91.1169, Culture=neutral, PublicKeyToken=3df3cad1b7aa5098' System.IO.FileNotFoundException: Could not load file or assembly 'RemObjects.Hydra.DesignTime, Version=5.0.91.1169, Culture=neutral, PublicKeyToken=3df3cad1b7aa5098' or one of its dependencies. The system cannot find the file specified. C:\Source\MyDirectory\WPF\Common\Hydra\My Project\licenses.licx 1 MyProject

The license manager shows that I have a valid license with an expiration date in 2019. I’ve tried reinstalling and also deleting my project’s ‘Obj’ folder.

Can someone help me fix this problem?

Thanks!
Jeff


(antonk) #2

Hello

Could you say which exactly VS version do you use and show the contents of the C:\Source\MyDirectory\WPF\Common\Hydra\My Project\licenses.licx file?


(Jeffrey Lange) #4

Hi,

Visual Studio Version:
Microsoft Visual Studio Professional 2013
Version 12.0.40629.00 Update 5

Licences/licx file contents:
RemObjects.Hydra.VisualPlugin, RemObjects.Hydra
RemObjects.Hydra.NonVisualPlugin, RemObjects.Hydra
RemObjects.Hydra.WPF.VisualPlugin, RemObjects.Hydra.WPF


(antonk) #5

I’ve jsut tried this Hydra build on VS 2013 installed on a fully updated Win10 host and everything worked just fine.

So let’s start from the very beginning.

Please try to build the sample WPF project c:\Users\Public\Documents\RemObjects Samples\Hydra for NET\Mixed Mode\C#\ManagedCSharpWpfPluginModule\ManagedCSharpWpfPluginModule.csproj

Does it work for you?

Also could you check that the RemObjects.Hydra.DesignTime, Version=5.0.91.1169 is present in the GAC ?


(Jeffrey Lange) #6

I am able to compile the ManagedCSharpWpfPluginModule.csproj sample file successfully with no errors.

I do not see RemObjects.Hydra.DesignTime, Version=5.0.91.1169 anywhere in my C:\Windows\assembly directory.


(Jeffrey Lange) #7

The only place I see RemObjects.Hydra.Designtime.dll is in here:
C:\Program Files (x86)\RemObjects Software\Hydra for .NET\Bin


(antonk) #8

Hmm, it should also be present as c:\Windows\assembly\GAC_MSIL\RemObjects.Hydra.Designtime\5.0.91.1169__3df3cad1b7aa5098\RemObjects.Hydra.Designtime.dll , otherwise the sample plugin wouldn’t be able to build.

Could you also try to build this plugin: c:\Users\Public\Documents\RemObjects Samples\Hydra for NET\Mixed Mode\C#\ManagedCSharpPluginModule\ManagedCSharpPluginModule.csproj

If it doesn’t fail then please send us your plugin project to support@ so we’ll investigate this specific project.

Thanks in advance


(Jeffrey Lange) #9

So I used gacutil to install the two dll’s that were missing from my GAC:

* RemObjects.Hydra.Designtime.dll
* RemObjects.Hydra.dll

Now my project compiles correctly as expected. I’m not sure if these files didn’t get into the GAC because of my company’s Win10 security policy or there was a problem with the Hydra install.

Thank you very much for your help and I will let you know if I run into any other issues.

Regards,
Jeff