Fail Installing DataAbstract on Delphi 2010


(Armindo DA SILVA) #1


we have two licences of DA for Delphi.

I have installed mine without any problem.

Now my collegue want to work on my project so he started to install DA for Delphi on Delphi 2010.
No problem for installing.
He launch (for the first time) Delphi, and we can see RO and DA on the Delphi Start Screen and no Error.
Then he closes delphi. The second time Delphi is launched this time he has errors for loading all the bpl of RO/DA. Something like

cannot load the package XXX_D14.BPL specified module not found. would you like to load this package on the next project loading ?

Any idea ? these package files exists on the folder.

Thanks for your help2018-06-13_15-39-37

(EvgenyK) #2

have you selected Append to Delphi's override paths item during installing DAD?
if not, can you make sure that path to ...Dcu\D14 is present in %path% variable

(Armindo DA SILVA) #3

Append was selected and in pah DCU\D14 is present among all others (see Screenshot).
and Strange things even if you ask the installer to install in c:\RO instead of program files, it still install some dcus in program filesremobjects\everwood\dcu\D14


(EvgenyK) #4

everwood is always installed into program files. this is as designed.
try to reboot that pc. sometimes it resolves some unexpected errors.

(Armindo DA SILVA) #5

at the begining we have installed using the default installer path (program files), we have rebooted the PC, but no way.
We have changed the installation path because this PC has a lot of third party comps, so a lot a folder in the Delphi Paths, and a at certain length, Delphi ignore some paths.

Could it be that RO requires some extra DLL that are missing ?

(EvgenyK) #6

RO_IDE package require Everwood package. pls check that it is installed and path (C:\Program Files (x86)\RemObjects Software\Everwood\Bin) to it is present override path settings.

also you can try to:

  • open delphi
  • ignore errors that ROD packages aren’t found
  • open C:\Program Files (x86)\RemObjects Software\Everwood\Source\Delphi\RemObjects_Everwood_D14.dpk and install
  • open ROD\Source\BuildPackages_D14.groupproj
  • manually rebuild and install all packages
  • the same with DAD packages

(Armindo DA SILVA) #7

We have tryed this and same problem, building the package manualy doesn’t solved the problem. you sometime can compile it, sometimes not. And when you succeed installing it, you failed loading the BPL next time you load Delphi.
No problem on Delphi Berlin on same PC.

(EvgenyK) #8

as I can see, Delphi tries to load .bpl from C:\RO\RemObjects SDK for Delphi… folder

but actually, here another path is used: C:\RO\RO-SW\RemObjects SDK for Delphi… folder

I can suggest uninstall DAD and install it from scratch. it will allow to remove invalid entries in Delphi 2010

(Armindo DA SILVA) #9

yep that is an old Screenshot, we have already removed, and done the install on the default folder of the setup.
I suspect that this version of delphi is unstable.

(EvgenyK) #10

so is this problem solved?

(Armindo DA SILVA) #11

Continuing the discussion from Fail Installing DataAbstract on Delphi 2010:

Not really, he thinks of compiling a RO DLL With Berlin to be able to use RO with D2010…

(EvgenyK) #12

it was issue, when path in delphi overrides was quite long so our installer didn’t add our paths to this variable. it was a reason for such issue.

(Armindo DA SILVA) #13

Hi Evgeny,
Problem is solved ! Thank you for your great support.
Best regards