"French Language" - RemObjects Elements Installer

(Kosta Key) #1

RemObjects Elements Installer is changing language to French by default.

Please have a look into registry key:
UILanguage “1036”

However my VPN Machine (Win10 Enterprise) is physically located in NY-US and regional settings are set to en-US only.


(marc hoffman) #2

i don’t believe that is our doing. i have seen the same on stock clean-vm installs of VS on an english system; somehow the VS installer shows in french (but vs itself will be fine)…

(Kosta Key) #3

Hi Marc,
I think it’s an installers issue, because when I installed and updated to VS with no Elements, it remains 1033 (English United States) locale code in “UILanguage” registry value, but once I have installed Elements, the value was changed to 1036.

It does not affect Visual Studio UI Language, but it affects installer when it comes to add/remove VS components.


(marc hoffman) #4

Hmm. i checked, and our installer does not touch the UILanguage setting. in fact, i can’t find either string, “UILanguage” or “1036” in our installer code base, at all…

So if i understand correctly, this key doesn’t/didn’t exist initially (or is not set to 1036, at least), and after merely running our installer and doing nothing else, you see it set to 1036?


FWIW, its set to 1033 here on my system; before and after running our installer.

(marc hoffman) #5

One more question: are you using/did you install the VS Shell, from our setup? or did you install Elements into an existing VS2015 installation?

(Kosta Key) #6

Hello Marc,
Only with VS Shell from RO Elements, setup installer is changing to 1036 locale code, then I execute vs2015.3 updater which displays in French UI. I had to change to 1033 or 0 in “UILanguage” manually, in order to have English UI.

On another hand, I did download VS Shell 2015 from official US Microsoft’s website, and installed VS Shell 2015 then ran vs2015.3 updater with English UI, that means without RO Elements Interaction “UILanguage” is set to 1033.

Before all of these steps, I didn’t have any Visual Studio Installed on my Machine.

Thank you.