Hydra 5.0 and non-Visual Plugins ERROR

(Baptist Kaufmann) #1

I Installed the new Hydra 5.0 (, and tested with my mixed mode Application (Delphi Host/ Oxygene plugins).
so I noticed that i can not load the non visual plugins anymore. I got “interface not supported” error in THYVCLCrossPlatformPluginWrapper.SetHost(const aValue: IHYHost) Line “(CrossPlatformInstance as IHYCrossPlatformPlugin).Host := lValue;” .

I made also a simple Example based on the unmanaged delphi host and with a managed and an unmanged plugin and got the same result with the unmanaged plugin. The new “Remobjects.Hydra.dll” is in the application path.

What’s going wrong?

(EvgenyK) #2

can you share your simple testcase, pls?
you can attach it here or drop email to support@

(Baptist Kaufmann) #3

I have attached my testcase.
Delphi Host build with Delphi XE2
Plugins with VS 2015 Community Edition.

ThanksHydraTest.zip (199.2 KB)

(RemObjects) #4

Thanks, logged as bugs://77669

(RemObjects) #5

bugs://77669 got closed with status fixed.

(Baptist Kaufmann) #6

Please, tell me what has been fixed and where can i download a fixed version.

(antonk) #7


There was a bug in the NonVisualPlugin definition (missing COM interface). Please send a mail to support@ with your account name on remobjects.com and we’ll provide you a fixed build.

Sorry for inconvenience

(Sebastian May) #8

I’m experiencing the same problem. Can you please send me an updated build, too?


(antonk) #9

Please do the same - send a mail to support@ with your account name.

(Sebastian May) #10


I got the bugfix release from your support team, however, I’m still having the exact same problem. I’m using Visual Studio 2017 and Delphi XE 10.


(antonk) #11


Please double-check that VS did actually rebuild the plugin with the updated assemblies. Readd the Hydra references and delete the bin and obj folders in the project’s folder.

Hope that helps

(Sebastian May) #12

Hi Anton,

Do you have any news on this issue?

Today I tried again from scratch. Everything works fine on a .NET host, however if I try it on a delphi host with a viusal plugin, I still get the same error (it works fine with a Delphi host and a non-viusal plugin). Any help is greatly appreciated as this is a showstopper for my project currently.


(antonk) #13


Please send a testcase to support@ and we’ll try to fix this ASAP

Thanksi in advance

(EvgenyK) #14

A post was split to a new topic: Hydra 5.0 and non-Visual Plugins ERROR