"Import from .NET Assemblies" missing


I’ve successfully installed version of Hydra on my computer. Everything seems to be installed correctly in both Visual Studio 2019 and Delphi XE4, including project templates and packages.

However, the “Import from .NET assemblies” menu is missing from Delphi’s Tools > Hydra menu. The only sub-menu I see is “Hydra Package Settings”.

In terms of compiling projects on both sides, no issues at all. However, if I were to update an interface significantly in a .NET plugin project, it would be difficult to update the imported .pas file, not to mention almost impossible to import a new plugin.

Is there any other way to import a .NET assembly in Delphi? I tried the regedit trick found in similar posts in order to add a VS 15.0 (2017) key and InstallDir string value before reinstalling, but the menu is still missing.

Installing a more recent version of Hydra (VS 2019 integration started in June 2019 release according to the changelog) is not an option at the moment.


I’ve tried solution with VS2013 from Hydra 5 Doesn't Install Import from .NET Assemblies and it works.

Setup contains ‘VS Integration’ section: