Linux Island Project can be created but not reopend


We connect via SSH to the remote server and (depending omg platform, but I think its the case for Linux) then run a small debugger stub on the remote that interacts with GDB. So GDB would see the connection as coming in from localhost, yeah.

Any time!

1 Like

bugs://84451 got closed with status fixed.

1 Like

We cannot reproduce here the issue “84450: VS: cant reopen Island/Linux project, unless TargetVRamework is set”. I tried to create new Island Linux console app, save it, close and open again. The project is opened fine, no dialog prompt is shown. Can you give me the steps on how do you reproduce the issue?
Thanks in advance.

bugs://84447 got closed with status fixed.

bugs://84450 got closed with status cannotrepro.

Hello Victoria.

Please find attached screenshots from visual studio

a) Dialog on when opening the project
b) (new) after Update of either Elements or Visual Studio an error message
c) output after project created
d) output after project failed to laos
d1) dont worry about calinux006 or 007.

I still use Elements since this is the matching version but updated Visual Studio to 2019.2 today. This didn’t change anything. The platform selection is still
Hope that helps you.

Honestly as long as I can connect to a Linux device using Water I’m happy so far. All the other project types seem to work.

Kind regards
Mike Screenshots & output.

error_opening_islandproject output_window_load_of_existing_project_failes.txt (25.9 KB) output_window_project_created_the_first_time.txt (57.0 KB)

PrismProject? @viktoriad, was that still something we have in code or could this indicate some leftovers on Michael’s machine from a VERY old install?

Hello Marc,

I was wondering about this too. I don’t remember exactly where I found it, but maybe in the project template. I thought that PrismProject is a certain kind of leftover of leftover in Oxygene.

This machine is old but I started to use it last year after having gotten rid of the heat-pipe.The OS is Win 8.1 and I cannot imagine that either a computer that had Prism installed does still exist here at my site. The ‘disk’ is a straight copy of a master ‘disk’ which has just a few hardware utilities installed. No registry key hinting at Prism can be found.

Just in case it’s important for you. From my perspective making that particular part work in VS too is a nice to have but not more. Water does have everything I need personally. Why does the same solution works brilliant and without a change in Water. So I guess the whole thing is about VS.

It’s just a guess. When I choose a template during the process of creating a new project I have tow options if filters are on. Option 1) is a .net Core project and 2) is a command line program in Island.

As far as I remember long time ago there was a thread about a similar error, which exactly this dialog showing up. And your reply was about having at least .net core installed just because that VS to be


The .net core settings in the project options don’t match what I have installed, maybe because I don’t use Win 10 in this configuration (swappable disks).

And if I try to select .net core in the project options default values are presented first and when I expand the dropdown box there is no option left to choose from. Which makes sense in my option.

[BEGIN EDIT] Maybe I tried out Oxygene years ago just to figure out if the noise from the heat-pipe is outweighed by the speedup gained. The last time I had a ‘real’ Prism installed must have been almost a decade ago. I had no access to Visual Studio before the Community Edition arrived and I can fairly imagine that I used the VS2012 or later (the grey VS after the blue VS 2010) on a generation of computers the one before I threw away last year. The bare-bone VS provided by you 2015 but on a different machine with Win 7 installed. This machine run into serious troubles with a corrupted Windows Update and together with a pretty slow hard-disk controller they ended up where they have should been put from the very first day on.

I doubt it’s a left over from my side. Thought about that too.

In general I used RO-SDK for .net with SharpDevelop which is in the state ‘is as is with no a future option’ for years now. So Water or Fire are a perfect replacement that go way beyond what I’m used too.

I found registry entries for VS9 and VS 16 but those for VS9 are empty. One key can be found for DownloadManager, Connected User, … and for SQM and such things. All of them empty.



Elements is quite “out-of-date”. We did a big bunch of fixes since that beta. Your issue could be fixed in the latest build as well.
Also what are the steps to reproduce the retargeting dialog problem? What would I do? Create a new island/linux console app, close and open it again? Do these steps trigger the retargeting dialog for you?

1 Like

Hello Victoria!

I’ll give the new release a try. 2522 is the release active at the time of your reply, so it did work and the one in which allows to connect to a Linux target device from Water. That’s why I kept it.

Yes, these are the steps.

Create a project, save it und open it.

a) Create Project works.
b) Close it
c) Open it once again
c1) the dialog shows up
c2) Project is loaded until I say ‘OK’ in c1 no matter what option I choose
c3) Project (Project Manager) remains ‘unloaded’
c4) In the Editor Window the error message shows up.

No idea why. But if things work on other machines don’t work. The whole thing works in Water. We are talking about about command-line applications at a very early stage.

I am using Oxygene as the programming language. In general ‘all’ other ‘technologies’ work, for example .net or Mac.

My guess is that it’s either the .net Core settings which hint at a version that is not installed, even after updating and installing VS with default settings offered during a click through install.

I already had all targeting packs installed just for testing and nothing changed. So the error message is not about a dependent on the .net framework. Or there is something odd in the project template.

Usually I don’t care about VS anymore, because the features are available in Water too. I miss nothing. I’ll simply uninstall Visual Studio and the problem is gone for. I’ll keep it as long as you try to fix this issue, if you try to do. Maybe there is a difference between Windows 10 and Win 8.1. As a developer that has to cope with Delphi I’m used to be happy about those thing that work.

Or the whole thing has to do with the ‘missing’ or different settings concerning the architecture.

Don’t do anything at the moment. I just checked the machine and I didn’t apply update to this disk for about one year. I used the machine for the Delphi betas and Denial this year too. So I just copied the master-disk for this computer. I usually try to simulate a very realistic scenario for a typical developer machine.

I’ll do the updates first and may reinstall VS as well as Oxygene in the latest version and then we will see. Time will show.

Hello Victora!

I updated Windows, installed the latest version of ‘everything’ but the particular behavior we are talking about didn’t change.

Anything else works so far. Also debugging on my Raspberry improved and is more smooth now.

Selecting the appropriate platform works. aarch64 and play it loud also from within VS.

If I create the project everything works fine. From coding to remote debugging so far so good and even more stable.

I simply suggest that we leave things the way they are. Since no one else seems to be running into this issue … I’ll keep Visual Studio installed and continue with Water, which is my preferred path anyway.

You should not waste your life time in front of computers. Enjoy the weekend!

There is one thing left I have to check. It seems to me that an older project created in Water could be opened. But I will have to double and triple check that. So please don’t take this into account for the moment.