No message type registered for the requested path: Bin

Using latest stable release on a .NetFramework 4.7.2 if I use the standard remobjects DLLs everything works fine, after updating to .netstandard dlls I’m getting this error message:

‘No message type registered for the requested path: Bin’

That happens on the line where RO is trying to match url with their respective protocols, formats, etc.

We put all dlls inside of packages, our latest internal package contains the .net standard and regular dlls. Any ideas?

To be more exact.

The code where it fails is when I attempt doing something like these:

_channel = ClientChannel.ChannelMatchingTargetUri(aURI);
_message = RemObjects.SDK.Message.MessageMatchingTargetUri(aURI);

The channel works, but the message fails. The URL is just ‘supertcp://localhost:9005/Bin’

If I rollback to regular .netframework RO SDK dlls things work as expected.

Interesting, changing the url to ‘Bin’ works when using .net framework dlls, but it doesnt when .net standard, if i change it to ‘bin’ it worked. Do we have some sort of dictionary implementation with unique key now, but not before?

Confirmed. All our services worked with /Bin and once they are updated to the .netstandard packages we have to change them to be /bin to make them work.

Thanks for reporting this issue and sorry for the inconvenience it caused.

Thanks, logged as bugs://84000

bugs://84000 got closed with status fixed.