No symbols loaded for this document?


(mtiede) #1

What the heck? I was having trouble compiling my project after refactoring to create viewmodels in a separate project. When I compiled it in Water, it compiled without errors. Then if I went back to VS 2017, I could compile it and run it okay.

Now I was trying to debug something so I set a breakpoint in source in the viewmodel’s project. But at run-time I get, “The breakpoint will not currently be hit. No symbols have been loaded for this document.”

What? All I did was recompile. I didn’t change any options. I DID download a couple of new VS 2017 versions. I can still set breakpoints in the main project and those work. But I can’t even step into the viewmodels code.

I think the same thing is happening in Water. I do what I think is “step into” and it doesn’t hit the breakpoint I have set there. Nor does it “step into”.

Any suggestions?


(Carlo Kok) #2

Does it take changes? You’ll want to check if GenerateDebugInfo is set, and if building Debug (iinstead of ReleasE)


(mtiede) #3

I see that both projects say Debug in VS. I don’t know how or where to check GenerateDebugInfo.

I see:

<GeneratePDB>True</GeneratePDB>
<GenerateMDB>True</GenerateMDB>

In both project elements files.

… time passes …

I don’t know why, but now it works. I removed the viewmodels reference from the main project. Then added it back in (all in VS 2017). Then I tried to recompile and got the error about Echoes.dll that I reported elsewhere. So then I went into water and did a rebuild in there. Then went to VS and now the breakpoints work.

… time passes …

Now I may have a related problem or not. While coding in the viewmodels project, code completion seems broken in VS. I have system.net in the uses. But when I try to do “HttpStatus” and press Ctrl-Spacebar to get completion, it doesn’t have “Http” anything in the popup. If I go ahead and type “HttpStatusCode.” and press Ctrl-Spacebar, still no http choices. If I put in “HttpStatusCode.Ok” and compile it will complain that the case doesn’t match. If I then type in “HttpStatusCode.OK”, it compiles correctly without error. But if I then try to press Ctrl-Spacebar when cursor is on “OK”, the Output window will say “Unknown identifier HttpStatusCode”. I tried closing VS and reopening and still a problem.

Since I just updated VS, I think I will uninstall RemObjects and reinstall and see if there is still a problem.

… time passes …

Uninstall/Reinstall didn’t make a difference.

I noticed that although I put system.net in the uses, it wasn’t in the references. Adding the assembly System.Net did the trick. One problem solved.