Problem deploying iOS app to device

Im trying to deploy the app to my phone and I get

[ 52%] CreatingStagingDirectory
[ 57%] ExtractingPackage
[ 60%] InspectingPackage
[ 60%] TakingInstallLock
[ 65%] PreflightingApplication
2021-09-26 19:48:38.504 ios-deploy[65976:1690754] [ !! ] Error 0xe8000051: Could not inspect the application package. AMDeviceSecureInstallApplication(0, device, url, options, install_callback, 0)

I google that and get

I can deploy a vanilla tableviewapp to my phone.

No clue off-hand. I’ll have to have a closer look in the morning. :pray:t3:

I dont suppose you have had time to look into this one ?


Ok I tried a few times and did a few rebuilds and they now deploy, so I dont know what the issue was.

I did, but I have no idea, I’m afraid. All this deoployment stuff is a balck box to me. likke you, all i can do is google for the obscure error codes and pray…

i take it this only hapens for one specific app? or for any?

I posted again because it was another app so I tried the original one that had the issue and that deployed. I then did a clean and rebuild of the new one and that worked. I never no idea why they initially failed but it works now so Im ok.

1 Like

welcome to iOS development :rofl: