Relativity Server question


(Alan Olson) #1

I’ve been using a DA windows service for over a year, and I’ve decided to move to using Relativity server for our next “update” to our systems. I’ve been working the last couple days, and I have put together a relativity server to work beside our existing windows service.

I built it from scratch, and did not port over an existing schema. I wanted this to be fresh.

I just tried to apply a field update using it and i’m getting an error. I tested the same query/update on our existing windows service, and it worked without error.

The error i’m getting is “Data conversion error: parameter #37

Question - how do I go about and log the SQL which is generating this error?


(antonk) #3

Unfortunately it is not possible in Relativity (at least for now).

Create a new .NET server app and add your Schema there.

Btw which database / driver do you use?


(Alan Olson) #4

It is using ODBC.NET with a Pervasive.SQL ODBC driver.

I’ve compared the schemas for the table in question against my existing service, and they are the same. I’m confused. I don’t even have 37 fields in that table…


(antonk) #5

Could you send the working server’s .daConnection and .daConfig files to @support? Before sending the .daConnections copy it and replace username/password with dummy values.


(antonk) #6

Thank you for the files.

There is potentially a very big difference between Relativity Server and custom server app in your case: your server app uses custom DataAbstract.daConfig file. Could you double-check that the same modified DataAbstract.daConfig file has been placed next to the Relativity Server .exe file?


(Alan Olson) #7

yes, the same daConfig file is in my service app directory AND the Relativity directory.


(antonk) #8

Hmm. Give me some time, I’ll create a custom Relativity build for you with SQL logging. I’ll post it as a answer to your support@ mail.


(Alan Olson) #9

Thanks!


(antonk) #10

I’ve just sent you a mail with a download link for custom build of Relativity Server.


(Alan Olson) #11

Thanks anton. I will test it out this morning.

alan


(Alan Olson) #12

Anton -

Here is the log from Relativity:

5/7/2018 11:47:29 AM|||=====================================================
5/7/2018 11:47:29 AM|||SELECT "t0"."Description", "t0"."Filler", "t0"."OtherComments", "t0"."PostDateTime", "t0"."PubName", "t0"."PubNumber", "t0"."ReconID", "t0"."StartDateTime", "t0"."User" FROM "aprecon" "t0" WHERE ("t0"."ReconID" = 1749)
5/7/2018 11:47:30 AM|||+++++++++++++++++++++++++++++++++++++++++++++++++++++
5/7/2018 11:47:30 AM|||UPDATE "aprecon" 
SET
  "ReconID"=?,
  "Description"=?,
  "PubNumber"=?,
  "PubName"=?,
  "User"=?,
  "StartDateTime"=?,
  "PostDateTime"=?,
  "OtherComments"=?,
  "Filler"=?
WHERE 
  ("ReconID"=?)
5/7/2018 11:47:30 AM|||Parameters:
5/7/2018 11:47:30 AM|||@OLD_ReconID|Int64|
5/7/2018 11:47:30 AM|||@Filler|String|
5/7/2018 11:47:30 AM|||@OtherComments|String|
5/7/2018 11:47:30 AM|||@PostDateTime|Double|
5/7/2018 11:47:30 AM|||@StartDateTime|Double|
5/7/2018 11:47:30 AM|||@User|String|
5/7/2018 11:47:30 AM|||@PubName|String|
5/7/2018 11:47:30 AM|||@PubNumber|String|
5/7/2018 11:47:30 AM|||@Description|String|
5/7/2018 11:47:30 AM|||@ReconID|Int64|
5/7/2018 11:47:30 AM|||*****************************************************
5/7/2018 11:47:30 AM|||UPDATE "aprecon" 
SET
  "ReconID"=?,
  "Description"=?,
  "PubNumber"=?,
  "PubName"=?,
  "User"=?,
  "StartDateTime"=?,
  "PostDateTime"=?,
  "OtherComments"=?,
  "Filler"=?
WHERE 
  ("ReconID"=?)
5/7/2018 11:47:30 AM|||Parameters:
5/7/2018 11:47:30 AM|||@OLD_ReconID|Int64|1749
5/7/2018 11:47:30 AM|||@Filler|String|                                                                                                                                                                                                        
5/7/2018 11:47:30 AM|||@OtherComments|String|This is a test
5/7/2018 11:47:30 AM|||@PostDateTime|Double|42755.5068215162
5/7/2018 11:47:30 AM|||@StartDateTime|Double|42746.551073831
5/7/2018 11:47:30 AM|||@User|String|mgangadeen                    
5/7/2018 11:47:30 AM|||@PubName|String|EMERGENCY PHYSICIANS MONTHLY  
5/7/2018 11:47:30 AM|||@PubNumber|String|6737
5/7/2018 11:47:30 AM|||@Description|String|mgangadeen 1/11/2017          
5/7/2018 11:47:30 AM|||@ReconID|Int64|1749

This is from a console test app. Using DALINQ, I do a simple query, and then update a single record. The query SQL appears fine, as does the update sql. But, this is the error i’m getting from my client console app:

Unhandled Exception: RemObjects.DataAbstract.DAUpdatesFailedException: One or more updates failed to apply on the server.

1749: ERROR [22018] [Pervasive][ODBC Client Interface][LNA][Pervasive][ODBC Engine Interface]Error converting to numeric type: Parameter #6.
ERROR [01004] [Pervasive][ODBC Client Interface][LNA][Pervasive][ODBC Engine Interface]Data truncated column: PubNumber.

   at RemObjects.DataAbstract.Linq.LinqDataAdapter.ThrowFailures(List`1 changes, String failureMessage)
   at RemObjects.DataAbstract.Linq.LinqDataAdapter.ThrowExceptionForFailedChangeDeltas(Delta[] deltas)
   at RemObjects.DataAbstract.Linq.LinqDataAdapter.ProcessPendingChangeDeltas(Delta[] serverDeltas, IDictionary`2 originalDeltaChangeIds)
   at RemObjects.DataAbstract.Linq.LinqDataAdapter.ApplyChanges()
   at RelativityTest.Program.Main(String[] args) in D:\dev\miller\RelativityTest\Program.pas:line 45

Am I correct in my assumption that the parameters are zero-based? If so, which parameter is this failing on?

Also, OLD_ReconID is a parameter, but it not in the parameter list. I assume this is used by DA?


(Alan Olson) #13

Well, now that I look at that log again…its doing two updates! I didn’t realize that the first time. Why is it doing two updates when in my code i’m only calling UpdateRow() once? The first time there is no data…which explains the error, but the second update has the proper values.

confused.

alan


(antonk) #14

Hello

That’s not two updates actually. This is a command being prepared and then executed.

Still the log is really helpful. It contains a thing that really worries me. Investigating it now.


(Alan Olson) #15

what part worries you?


(antonk) #16

Answered via PM. Please try the new custom Relativity build too


(Alan Olson) #17

This time it worked. Thanks so much for that fix. I need to do some more testing, but this may have fixed an issue I’ve run into for a little while now. This hasn’t been reported by anyone else?


(antonk) #18

No. Anyway I’ll retest this fix and it will go into the next Beta


(Alan Olson) #19

Hi Anton -

I had a few minutes, and I did some more testing w/ the revised Relativity server today. THings that were not working over the past few weeks seem to now be working, so it appears whatever modifications you made has solved my issues.

When is the next beta scheduled to be released?


(Alan Olson) #20

Hi Anton -

Just doing some project planning here - I was wondering when you are planning to release the next beta for DA/ROSDK?

Thanks

Alan


(antonk) #21

Hello

The next Beta release is planned for tomorrow