ROServiceImporter crashes


(ndelic) #1

When I run my RO server in Windows VM and try to connect to it from ROServiceImporter on my Mac (Mojave 10.14.2, Xcode 10.1), ROServiceImporter crashes when I enter path to my server and click Go. I can ping the VM, so the path appears to be ok. Is there a log somewhere that I can check? I tried Console in Utilities but couldn’t find any useful information there.

Is there another way to generate swift interface for Xcode app?


(ndelic) #3

Follow up - crash report attached.

crash-report.txt (127.7 KB)


(marc hoffman) #4

Curious. which version is that? can you try with the latest (I’ll put it in your Personals), I think this might be a bug in Elements RTTL that was fixed recentrly-ish.


(ndelic) #5

Unfortunately, version from private downloads doesn’t work. I use the version available in RODA .1377. As far as I can see, the version is 9.0, the same as the one you sent me.

Crash report attached.

ROServiceImporterCrashReport.txt (125.6 KB)


(marc hoffman) #6

By which you mean it crashes with the same, attached error?


(ndelic) #9

Yes, crash report is from the version you sent me. But no error message is displayed, the app just dies.


(marc hoffman) #10

Hmm, I cannot reproduce any crash with the build I sent you yesterday. any error condition i tried to enforce (eg a bad host name) shows a proper exception message, and a proper URL imports fine…


(ndelic) #12

I just crashed it again with yesterday’s version. Does crash report tell you anything?

crashReport.txt (128.9 KB)


(ndelic) #13

Are there any special steps needed for installation of RODA for Xcode? Or is merely unpacking of dmg enough?


(marc hoffman) #14

It does, it tells me its the crash we fixed a couple months ago, and that I cannot reproduce when running the exact same version I sent you (but which does/did happen with older versions). The only explanation I have is that shoehsw you’re not running the version I sent you in Personal downloads yesterday, but 9.4.

thats enough. But what I sent you was .zip with the ServiceImporter.app in it. It is an completely autark app and does not depend on anything else.


(ndelic) #15

I’ll try to re-download and get back to you.


(ndelic) #16

I double checked, it’s the .1378 version, crashed it again. Should RODA be embedded in the .app package? Because there are no dll’s there. If it’s running on Mono, that is.


(ndelic) #17

Correction, there is RemObjects.SDK.dll but no DataAbstract. My server is DataAbstract, could that be the case?


(marc hoffman) #18

no. as i said, the app is self contained, it’s a native cocoa app, and it doesn’t need DA, or Mono (except the latter for .NET codegen).

what are the exact steps for the crash, maybe i’m missing something there. but given the dal stack in the crash report, there really is no explanation, as that IS the bug that’s fixed.


(ndelic) #19

I start DA server in Windows VM, start ROServiceImporter on the Mac, enter http://server:port/bin and click Go. Then it crashes. If I connect to DA server from within VS2017 I can generate Intf file but not from Mac.


(marc hoffman) #20

Can I TV into your system again?


(ndelic) #21

check email