Schema Modeler login


(FireSide Experience) #1

I am being asked for a username and password when accessing the schema modeler. What username and password does it want? Our Relativity server is on AWS connected to a SQL server also on AWS.

Thanks!


(antonk) #2

Schema Modeler requires user credentials with administrative access to be able to update schemas hosted by Relativity Server.

By default these credentials are Administrator / Relativity if the Relativity configuration is stored in the local file system or Administrator / [AWS instance ID] if the Relativity configuration is being stored in Amazon S3 bucket.

Current host’s AWS instance ID can be found at http://169.254.169.254/latest/meta-data/instance-id

Please note that it is highly recommended to change default credentials immediately after the Relativity Server is installed. The best approach is to remove Administrator login definition at all and to register some unique username / password combination


(FireSide Experience) #3

thank you, that worked perfectly :slight_smile: Now the last piece to my puzzle is for some reason I can’t see the tables I have on my SQL Server. Everything looks like it is connected correctly and to the right database. Any thoughts about what I might be missing?

thanks again!


(antonk) #4

That’s an interesting question. Please check that the db user you use to connect to the database have sufficient permissions to read the INFORMATION_SCHEMA.TABLES view.

Also please could you try to connect to this server instance using MS SQL Server Management Studio and check if you see the tables there?

Also could you execute this query in MS SQL Server Management Studio

SELECT TOP (1000) [TABLE_CATALOG]
      ,[TABLE_SCHEMA]
      ,[TABLE_NAME]
      ,[TABLE_TYPE]
  FROM [TestBase].[INFORMATION_SCHEMA].[TABLES]

and show its result?

Thanks in advance


(FireSide Experience) #5

Hi Antonk,

thank you for answering…

I doubled checked via SQL Manager and yes all the tables appear there.

Running the above SQL I get the result on the Twonk db.


(antonk) #6

This is the same query that is used by Schema Modeler to retrieve table names. Could you please double-check that your connection defined in the Schema Modeler is not broken?


(antonk) #7

The login you use in the connection definition was missing db_datareader / db_datawriter roles on the target database. Thus it cannot read the tables list (or anything else from this database). Fixing permissions will resolve this issue.

I’ll log an issue to better reporting such cases in the Schema Modeler


(RemObjects) #8

Thanks, logged as bugs://79564


(FireSide Experience) #9

Antonk,

That seems to have worked. Thanks :slight_smile: Now trying to update my table definitions in Fire. Doesn’t seem to want to take my password. I have tried the Data password and the DB Login password but neither work. What password is it looking for?


(marc hoffman) #10

I believe this would need the Data login, which depends on what kind of Login provider (static, IIRC?) you have configure for the Domain.