Trial installation does not integrate with VS2017 Enterprise


(OxyEager2008) #1

A collegue of mine installed the latest Elements version on a machine with VS2017 (not sure of edition) without problems, integrated just fine with existing VS.

I tried the same, but with Elements 30 days trial using RemObjects Elements with Visual Studio 2015 - and it did not integrate (obviously the name implies only VS2015 for which I also tried on another machine with VS2015 Enterprise installed and was working fine).
Is the install file special for trial and not updated to integrate with VS2017 ?
If yes, when will it be available for VS2017 ?
(I would like to evaluate the use of Oxygene with VS2017 which is much faster than VS2015).

Another thing is I tried to install on a clean W7 machine without VS, then using the “bundled” VS2015 Shell version.
This was a very frustrating experience, extremely slow, crashing, lagging, in other words totally useless.
Did I do something very wrong ? Others with same experience ?

(Carlo Kok) #2


The current trial does not support vs2017 yet. We’re working hard of 2017 support (the betas already have it) but it’s not complete yet to be able to be released.

The “Shell” has some bugs (the shell itself), we usually recommend to use Visual Studio 2015 community instead. (Mainly, the html editor is slow in shell)

(OxyEager2008) #3


You talk about the free trial not ready yet.
Does this apply to commercial version as well ?

I found much more than the HTML editor was slow in shell.
My experience was that more or less every aspect of developing was slow, even typing code was lagging perhaps half a second per character !!

(marc hoffman) #4

All licensed users have access to our weekly beta builds, which includes VS2017 support, mostly stable and useable at this point.

We’re planning to lock down and ship the next release soon, at which point we’lol also update the trial, but at the moment it’s mostly coming down to dotting the last few Is and crossing the last few Ts for VS2017 — which required huge changes, refactoring and rewrites to support because (a) Microsoft completely changed the APIs and (b) they are still flaky as hell even in RTM, and we have to work around all that :wink:

(Henry Chan) #5

When will start to support VS2017 ? tks!

(marc hoffman) #6

Elements 9.1 will add support for VS2017. it sound be out in the next few weeks, and is in gamma now.

(estechco) #7

Is this still the case with 9.1?

I’m curious why the download section doesn’t (yet) show a VS 2017 shell?

(marc hoffman) #8

9.1 integrates with VS2017. but there is no Shell yet, so you’ll, have to have 2017 installed beforehand, whether Enterprise, Pro or Community.

(LoveN) #9

I have VS2017 Community installed and after installing Elements 9.1 It doesn’t integrate with it.

(marc hoffman) #10

Did setup show the option, and did you check it? I assume you are sure you have Community, and not some Express edition?

I’m pretty sure 9.1 integrates with VS2017, since thats a tent-pole feature of this release, and just about everyone here at RO is using VS2017 by now. If setup is not detecting your VS2017 install, something must be off, and wed have to investigate…

(LoveN) #11

Yes, I’m sure I have Community edition. And no, the setup do not show the option. Only option to install VS2015.

(marc hoffman) #12

Odd. someone from the VS team will need to investigate this issue in more detail, next week.

(marc hoffman) #13

So just to be clear, this option does not show for you? And you are using the installer?

(LoveN) #14

Yes. thats te version I’m using.
Here are some screenshots:

(LoveN) #15

And after installing VS2015, The option to integrate with VS2017 appeared. But why I should install 2015 to be able to integrate with 2017?!?!?

(marc hoffman) #16

Good question, yes, it should not. I believe this could be a bug in the combination of not having VS20-15 installed and using the installer that does include the VS2015 Shell. I will get that reproduced, looks at and fixed for the next build. thanx!

(RemObjects) #17

Thanks, logged as bugs://77890

(marc hoffman) #18

Yup, found the problem and i’ve already fixed it. pending formal testing, we’ll probably ship an updated public build soon.

(RemObjects) #19

bugs://77890 got closed with status fixed.