TROSocketOpenSSL slow


TROWinHTTPServer requires admin rights if case it isn’t configured with netsh add urlacl.

you can register your certificate with netsh add sslcert

OK, well I’ll try that later, but initial checks with the Indy Http server are promising. So far, everything looks to be working as expected, which means it must be the RO Socket which was causing the issue.


I wonder why self-signed certificates work as expected and Let’s Encrypt certificates don’t.
We have plans to implement native support for Let’s Encrypt certificates in RO so this issue will be reviewed during implementation and testing of this feature

1 Like

That would be awesome, let me know when you want someone to test that :wink:
For now, I’ll be copying the files from our webserver to this server’s folder every 3 months, so I need to put something in place to automate that.

So far, all testing has shown it is working perfectly now, with Indy.

When testing this, don’t forget it worked fine with the mega demo and my issue only came about when people were testing on windows chrome and edge. All worked fine for me on apple devices, and localhost.