(unamed) in debugger locals

Run the attached iOS app in the simulator, with a breakpoint on line82 of AppDelegate.pas and hit the simulate visit button.
As seen in the image I cant see the properties of place. It just says (unnamed) although its able to show the value. The other thing is that I cant add a watch for “place.name”. It just says no instance member on CLPlacemark.


LocationApp.zip (1.6 MB)

Thanks, logged as bugs://85339

Is this with he Island or LLDB debug engine (you can check/switch in settings). Any chance you can reproduce this with a macOS testcase? that would probably help the debugger team fix this more quickly (everything is easy rwhne not having to involve iOS or a sim :wink:

Is that option dependent on not using Toffee v1 ?

I did a console app and I get unable to evaluate expression. Im not sure if thats the same issue. I would of expected to see all the properties but with nil assigned.

PlacemarkConsoleApplication.zip (650.7 KB)

Shoudln’t be. its there specifically for TooffeV1 (Island always uses the new Island DE, and its also the default on Big Sur and the only available option on Arm Macs).

The unable to evaluate is a known issue with LLDB 9and probably wont be fixed, as we’re focusing on making the Island Debug Engine useable everywhere. I’d appreciate of you could switch too Island Db bug Engine, and see how that fares form you; on Catalina/Intel, it should be mostly good for production use.

I cant see anything in the settings that looks applicable.

I didn’t think that was the issue. I’ll see if I can create a proper mac app using the same api.

I can’t make a screenshot now, because the option wont show on Arm, but the setting is there:

                    <string>Debug Engine</string>
                        <string>Platform ==[cd] 'Toffee'</string>
                        <string>UseLegacyToffeeMode !=[cd] 'False'</string>
                        <string>OSArchitecture !=[cd] 'arm64'</string>