[68209 Open] Oxfuscation doesn't work for satellite assemblies


(brian thomas) #1

FormsApp_I18N.5415.zip (69.0 KB)

I've attached a VS2008 solution for the attached C# .NET Forms "Hello World" app. It has a single Form with a single button. I've added localized resources for German de and French fr srings. The build creates satellite assemblies in the .\de and .\fr folders. The legend on the button has been localized, so in a German locale, the text will be German. I force the locale for the app to be German.

The solution also contains an Oxfuscation step. If I run the exe created before the Oxfuscation step, then the UI button has the correct German text.

But if I run the exe after the Oxfuscation step, the button has English (default) text rather than German.

Oxfuscation doesn't copy the .\de or .\fr folder, so I'm guessing that it doesn't handle satellite assemblies. What do I have to do to get the Oxfuscated exe to work correctly?


(RemObjects) #2

Thanks, logged as bugs://68209: Oxfuscation doesn’t work for satellite assemblies


(RemObjects) #3

bugs://68209 got closed with status wontfix.