Accelerate Framewokrk

Marc - I installed Fire (May 28) but I don’t see the Accelerate framework.

I see my Xcode is only 11.3.1 but I didn’t think that would matter?

I had to drop that from, the import because there were problems with it in the newer Xcode versions (some missing headers we could not work around). I’ll investigate if we can get this fixed, either nor or with Xcode 13 Beta next week.

Any update on this? I didn’t see it in 2639 either.

This should be fixed for the latest iOS 14.5 and macOS 11.3 SDKs,. (as well as 15.0 and 12.0), including the ones on SDK Downloads | Elements and the one shipped in 2641.

Not 100% sure f this was fixed before 2639 or in-between, but i’d wager 2639 should have it too because I don’t recall doing this this week…

Maybe I’m doing something wrong? (Not an expert on the interactions of the various SDKs). I ran Fire, opened my project (a Mac console project), right-clicked on References, then select Manage Reference. Accelerate still doesn’t show in the list. Ran Re-resolve too.

In case it matters, I’m running macOS Mojave 10.14.6. and I have Xcode 11.3.1 installed.


Check your Toffee SDKs/macOS folder under the Elements install. is it there? it is for me:

Where would I find that folder? I have been installing/updating Fire, but (in a long time) nothing more. Am I supposed to install the “Elements - Mac and Linux zip distro” also?

Oh thins is Fire, right. check two things:

(a) make sure yu have no old SDK downloads in ~/Library/Application Support/RemObjects Software/EBuild/SDKs. just delete the whole SDKs folder if its there

(b)choose Show Package Content in the context men u of in Finder, and then look in the ./ SDKs folder within in.

If you did delete anything in step 1, restart Fire to be sure.

I have both RemObjects and RemObjects Software folders under Application Support. I removed the SDKs folder under RemObjects Software (RemObjects had only Ebuild). Here’s how those folders look now:

I see Accelerate.fx is under both “Mac Catalyst 14.5” and “macOS 11.3”. How do i make it visible in Fire under Manage References so I can add it?

Seems that, every time I delete SDKs and restart Fire, it recreates Library/Application Support/RemObjects Software/EBuild/SDKs/Toffee/macOS 10.15 with lots of *.fx dated 10/31/2020, and omitting Accelerate.fx et al.

Any idea what that would be happening? How can I get Fire instead to look at the SDK inside its package?

Wait, you’re building for the macOS 10.15 SDK?

I’ve brought Accelerate back for macOS 11.3 and macOS 12.

Seems that, every time I delete SDKs and restart Fire, it recreates Library/Application Support/RemObjects Software/EBuild/SDKs

that’s because you’re building for an SDK rtha Fire doesnt have embedded SDKs for, so they get download. I’m not in a position now to update 10.15 (though i’m pretty sure I didn’t blacklist Accelerate until 11.x — but if its not there for 10.15 it’s not).

I can only suggest to switch to the macOS 11.3 SDK and Xcode 12.5 (you can still set 10.15 as deployment target for yore app, so it runs on Catalina, or even older versions of the OS), which, as per your screenshot, has the framework.

Bear with me - trying to feel my way along. So I switched to macOS 11.3 (as opposed to macOS - which I assume tries to use the latest) in the settings, after deleting the SDKs folder again. (Settings screenshot below)

Now, I get no references and the following from the Re-resolve:

Does that mean I need the older Xcode? Can you give me a pointer to how I can do that? (Apologies for the lack of knowledge - in the past, mostly this stuff “jsut worked” for me so it wasn’t an issue).

You need the newer Xcode. If you set the build log verbosity to Diagnostic in preferences, Ebuild will show you all the details. ew.g. for me:

D:                Xcode developer folder is '/Users/mh/Applications/'
                  Xcode Version is 12.5 (12E262), macOS Version is 11.4 (20F71).
D:                Supported macOS SDKs in local FXs:
D:                - macOS 12.0
D:                - macOS 11.3
D:                - macOS 10.15
D:                Supported macOS SDKs in Xcode 12.5:
D:                - macOS 11.3
                  No exact macOS SDK version was specified for target 'Toffee-macOS', using 'macOS 11.3'.

if you have a specific macOS version selected, you will need an Xcode that matches. if you have not, EBuild will determine the version thats in your selected Xcode, and then either use the local Fx files, if present, or download them, if not.

It looks like you have Xcode 11.3 active, so it’s picking the 10.15 SDK and downloading it if needed.

As mentioned before, I’m confused why that doesn’t have Accellerate, as I only removed it much later, but if thats the case, I cannot fix that now, you have to update to Xcode 12.5, to get macOS 11.3, or to Xcode 13 beta to get macOS 12.0 beta, to get my fix.

Thanks for the assist. I have 12.5 targeting 11.3 and all good now!

1 Like