After Mono-Update Problem w. Relativity Server on Linux ( Ubuntu 14.04 ) // again

Hello
After a Update on Ubuntu 14.04 with the newest mono Updates Relativity is not working anymore.
Seams to be a mono Problem.
Just for others do not install the lastest mono Updates…
I did file a bugreport https://bugzilla.xamarin.com/show_bug.cgi?id=44939

Shalom
Manfred

So it fails on the point where you try to GAC the MySQL driver?
This can be a some kind of drivers assembly issue too.
We’ll take a look on this next Monday.

Yes, and also when i try to start the relativity server on the command line.
But first the weekend.
Shabbat Shalom
Manfred

There are some breaking changes in the mono that won’t allow Relativity Server to start. We are currently working on the fix.

Hi
Is there any success / time-plan on the Mono Front?

Shalom
Manfred

Hello

There were a breaking change in the latest Mono (namely in Sockets code) that broke server channels. We already have a workaround that will be shipped with next Beta.
Promised new Mono’s TLS 1.2 support doesn’t work because Mono itself is broken (see https://bugzilla.xamarin.com/show_bug.cgi?id=40381 for details).

Unfortnately your issues seems to be caused by some issues during update process and I cannot offer any help with them. The only advice would be to completely remove Mono, including its settings and config files and to reinstall it again.

Hello

My mono-installation works now again. Did a complete new installation of the Server, after 3 days of try and error…
The Relativity Server starts now also. But when i try to open the Shema Modeler i get the Error:

I can also Access the Statuspage:

Relativity Server: v9.1.100.1267
Data Abstract: v9.1.100.1267
RemObjects SDK: v9.1.100.1267

Framework: v4.0.30319.42000
Operating System: Unix 3.13.0.42
Platform: Unix
In the Server Log is also the entry:

I did Disable SSL and also TLS (

Hello

Is by any chance AES enabled on the Relativity Server? The response looks like it is encrypted.

Yes AES is enabled, when i disable AES it works.

I need to check how SM handles the AES encryption. But that should not be related to Mono version

Found out that there seems to be a mysql net problem. Try to figure this out first.
Just as a question. The mysql net driver has to be 4.0?

I think 4.5 driver should work too.

Ok the Net- and Mono Problems are gone.
I can connect the DB with the Server Admin
But Serveradmin still shows the Errors in the Log

TLS is disabled, my Applications also refuses the connection.


There is no Error in the Log of Server Admin after the failed login from the App.

Relativity Server: v9.1.100.1267
Data Abstract: v9.1.100.1267
RemObjects SDK: v9.1.100.1267

Framework: v4.0.30319.42000
Operating System: Unix 3.13.0.42
Platform: Unix

Copyright © RemObjects Software, LLC. All rights reserved.

Ok did quite some testing.
It works with:

Relativity Server: v9.1.100.1267
Data Abstract: v9.1.100.1267
RemObjects SDK: v9.1.100.1267

Framework: v4.0.30319.42000
Operating System: Unix 3.13.0.42
Platform: Unix

Mono Version

Mono JIT compiler version 4.6.1 (Stable 4.6.1.3/abb06f1 Wed Sep 28 13:54:26 UTC 2016)
Copyright © 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
TLS: __thread
SIGSEGV: altstack
Notifications: epoll
Architecture: amd64
Disabled: none
Misc: softdebug
LLVM: supported, not enabled.
GC: sgen

What does not work is AES and TLS.
At least AES should work.

Thank you for your Help

Shalom
Manfred

Just in case - if you did enable the NEWTLS thing then disable it. It is broken on the Mono level. And if there is a Mono.Security dll next to the Relativity.exe then remove it as well.

Did ot find the NEWTLS …
But i have disabled TLS
Did delete the File Mono.Security dll, now there is no Erro in the Logfile.
AES is still not working…

As soon as i open the Shema Modeler the Error shows up:

If i disable AES it works also with my Application… But i would like a encryption…

I’ll investigate this today

Is there a solution available ?

Shalom
Manfred

AES seems to work for me. Seems you’ll need to redefine the Relativity connection file as the encrypted AES password attached to it is no longer valid. Try to recreate the .relativityClient file.

Is this with the newest Mono Update( it came out just today or yesterday. Did not install this until now beqause the last update caused all this work…