Android App crash on startup on 2809 and with aapt2


D:                      Checking repository
D:                      Package androidx.appcompat:appcompat found in repository

that URL totally gives me a 404 here. Not just from Elements, but also in the web browser:

app is stared and later i got message in log

Message: Failed resolution of: Landroidx/appcompat/R$drawable;


But it is google standard package and app is
Very simple. Is it working on your machine?
I dont understand why before this aapt2 all works on my windows machine… I have working app builded in older version…

I dont know either, but the first thing is to look act the log to see if we can get the actual error messages! because chances are there is more einfor there than conveyed by that one line exception message.

I’m not really set up to test that, right now.

I will try tomorrow with aar added to project wihout gradle process, we will see but today i have no power for it…

1 Like

Doubt that will make a difference, FWIW.

But on windows i used gradle the same way like on Fire…

Some difference must be somewhere… This is the simplest app i wrote like hello word but message did’t show… :grinning::grinning:

I will try of course to find out something more readable in log
But please try to run this simple app on your machine too

I don’t have something to run this on right now.

Hello Marc,
I did first simple app in android studio and second app in fire (I removed all unused refernces and I added only required - I saw them in first project in Android Studio.
Android Studio App built successfully and works fine in my physical android device.
The second app built in Fire crasch after start up. I searched in LogCat but I didn’ find any new message (only this one mentioned in Fire Log).
I did ebuild --dump for these applications.
They are below :
fire.txt (317.4 KB)
2.Android Studio
as.txt (286.6 KB)
One difference I saw is lack of R. in Fire app

I will not investigate more because i don’t have more knowledge (app is genereated in Ebuild process) → it’s beyond me.
This is only helpfull information from logcat :

That is all what can I do for you for this simple app.
Waiting for working Fire or any related info to help me build this simple app in Fire.
Best regards

Yeah so it really boils down to why does aapt2 not generate the R classes for all the packages, when aapt(1) did… :(.

Does this help?

or these

Marc I’m investigating right now , I removed , dependecies, add dependencies one by one and I can only say that in simple apk with references added from Android Studio Fire doesn’t work…
When i set in simple app AppCompatActivity something (app is starting but simple view is not loading) but i can’t debug oncreate - > breakpoin is not resolved,whe is inherited from AppCompatActivity when i inherit from Activity i can debug … … All things broked after migration to aapt2 and resources but as you know i test the sample simple application in Android Studio without any problem…
I can’t search longer I have to rerwite application wroten in oxy in Android Studio and leave youtr tools after few years because I have no idea why something what worked so far doesn’t work now without my ingenuity (simple app can’t be complicated to run - have some added references mapped from Android Studio - once again but they are the same I have so far…)
I loved your solution but when simple app doesn’t work what can I say… I have no time to investigate more… maybe I will rewrite it in AS in shorter time…
I checked dependencies and made very simple App in Fire without success but as I wrote with AppCompatActivity which is recomended by Google.
My library is based on AppCompatActivity and has been working so far…
I have ready to use app generated in older version of RemObjects on Windows but without aapt2-> after migartion to Fire and trying to run aab my application doesn’t work…
It is not acceptable especially because from 2 days I’'m fighting with simple app based on AppCompatActivity… because I found that here is a problem…
The worst thing is that dependencies hasn’t changed but I can’t run apk in Fire in new format…
Best regards

I removed all third party component. I leave only these needed for simple AppCompatActivty (google dependent) but it still doesn’t work in my environment.
I tried with simple app … the simplest. I know

I should write that i wrote app using your tools for .net.core earlier wpf windows, ios, android but now it is the first time i cant resolve problem…
Maybe I missed something but i compared to Android studio…
I tried but i have to give up because I have no more time…

Question is can we not to use aapt2 generate apk in old format and later manually pack to aab?
As i know we can’t but maybe is any other way to generated and working apk pack into aab?

UseAapt has bene changed to hardcoded always be true, a while back. I don’t remember the details, but I wouldn’t have done that if it had not been necessary, so I think aapt can no longer be used.

As a workaround, try this: grab the file for appcompat that Android Studio generates (or manually run aapt(1) on it to generate it), and just add it explicitly to your project.

R. Java for apocmpat from output AS?
Copy to my app folder?
Second question is why after changing to appcompatactivy in oncreate breikpoint is not resolved, can it be done by bad resources?
Activity works fine and I can debug…