Android app from Fire doesn't work with AppCompatActivity

Let’s focus on the issue at hand?

I’ve also tried in Water - with no success

OK but I still searching difference … If someone run it why not try…

Yes, that is the issue from the other thread, there’s no reason to believe this would have gone away. There’s two issues here, (a) aapt2 doesn’t handle spaces in filenames (that, I can hack around) and (b) when avoiding the spaces, it fails with “The device does not recognize the command.”, which we dint know why. Both clearly seem to be aap2 bugs.

I tried VS and Water because Evgeny wrote he used Water to run it.

Any news ?

I in middle of process fixing problem. Process goes, but slowly.

I keep my fingers crossed for you…

Can you give me some deadline-i have to say something my client…?

Sprry thatb this is taking long, but some things just aren’t a quick fix. :crossed_fingers:t3:

Meanwhile i suggest the workaround from the other thread.

I have to wait :sleepy: , because i don’t have time to experiment with workaround, I have to make changes in my other apps.

I’m told Eugene has a fix. which won’t be in .2813 for tomorrow, but I can probably/hopefully get you a new post-2813 build tomorrow or on the weekend that has it (no promises, as I’ll be traveling tomorrow, with limited online access).

1 Like

Nice, I’M waiting to test it…
The problem was directed to only compat library or for any third dependencies?
I ask becasue i have many dependencies in android. Apk and i want to know.
If you give me version I will give you feedback in short time.

1 Like

Im promised we’ll have a build with the fix on the next few hours today. I can’t promise at what time I can get it today, as I’ll heading to the airport in 2h and won’t be online for a while, maybe not until tomorrow morning, to put the new build out for you. I’ll see what I can do. :crossed_fingers:t3:

I’ll let Eugene reply to the technical details.

1 Like

Thank you :grinning:

1 Like

See PM for that part :wink:

1 Like

I have downloaded version from Personal, didn’t work, than noticed that it was 2714 not 2814 - date the same - one year earlier…
I’m trying now 2813 from Firehose

2813 (20230217-162338-elements-develop) from Firehose doesn’t work (in commit I can’t see any changes related to my problem).
Is this good version for me , or should I wait for another one (newer) ?

Unfortunately Eugene was not able to get the fix finalized today. I can’t say more as, as I said, I have been traveling and not been able to communicate with him directly/live. I’ll touch base tomorrow to see what the status is, he promised me to be around tomorrow to finalize it. :crossed_fingers:t3:

Thank you, have a nice and safe journey.

1 Like