Another WSDL, another problem

I struggling literally with all external SOAP web services I have to import with Service Builder since many years. I’m really thinking to just send self generated XML over HTTP instead of using that mapping in future…

First, in all cases I have to add InputChildrenNamespace -> * attribute to all operations, and there is not even a selection option in the drop down for it. But that’s not my current problem.

In the current case the RODL has mismatches with the WSDL types. I sent the WSDL to support email. With SoapUI everything works perfect it creates this request:

<?xml version="1.0"?>
<SOAP-ENV:Envelope xmlns:xsd="" xmlns:xsi="" xmlns:HNS="" xmlns:SOAP-ENV="">
  <SOAP-ENV:Body xmlns:ro="">
    <v1:MT_BESTAND_REQ xmlns:v1="">

and I got back this response from SAP:

<SOAP:Envelope xmlns:SOAP="">
   <SOAP:Body xmlns:xsd="" xmlns:xsi="" xmlns:HNS="" xmlns:ro="">
      <n0:MT_BESTAND xmlns:n0="" xmlns:prx="">
         <ARTIKELBESTAND MATNR="18797">
            <BESTAND WERKS="F10" BESTAND="79.0" SP_BESTAND="14.0" Q_BESTAND="5.0" MEINH="ST"/>
         <ARTIKELBESTAND MATNR="18798">
            <BESTAND WERKS="F10" BESTAND="80.0" SP_BESTAND="6.0" Q_BESTAND="11.0" MEINH="ST"/>

When I try to call the web service by RemObjects, with the imported WSDL, I see that the parameters are send wrongly structured, so SAP can’t find them:

<v1:MT_BESTAND_REQ xmlns:v1="">

So I started to investigate the generated types in Service Builder. I debugged the mapping and tried for hours different things and ended up with deleting the wrong element name of DT_BESTAND_REQ_MATNRArray. This helped to produce the desired request.

But on response I still struggling, I get an exception on mapping the response to the generated types.

and then on Continue:


To fix that I tried also several hours many possible ways but with no success. I’d be glad if someone could help me on a workaround because i’m running out of time on the project.

Also fixing the WSDL importer to avoid that problems would be great of course :slight_smile:

I’m using Delphi 10.3 Update 2 with RO SDK

Thanks, logged as bugs://83908

bugs://83908 got closed with status fixed.

Remoting SDK fixed that problem