App Store delivery problem

I’m getting an issue trying to upload an ipa file to the App Store with the transporter, giving the following error:

Asset validation failed (90164)
Invalid Code Signing Entitlements. The entitlements in your app bundle signature do not match the ones that are contained in the provisioning profile. According to the provisioning profile, the bundle contains a key value that is not allowed: 'true' for the key 'get-task-allow' in 'Payload/'. (ID: 31a8aa61-9c43-48dc-a7f3-bc7964499c5f)

I had the problem with a personal app I was trying to get onto test flight, so came back to an app that I’ve not touched in months, check the certificates are still good and replicated the problem as above. The odd thing is, I can see get-task-allow is set to false in the provisioning profile under the entitlements section, so where might this be coming from?
(using Fire

Wherever not comes from you cannot ship apps with get-task-allow = true.

I get that, I just can’t see where it is, especially since I just re-built the same app as I uploaded there fine a couple of months ago, and I’ve not done any work on that one so I’m assuming something has changed at the apple side, but the failure message is not helping.

This is a screenshot of the provisioning profile it is using, which shows it is false:

Do you have a custom entitlements file in your project?

Interesting question, as I see there is one in the resources folder for my personal project (no idea where it came from) but didn’t see any reference to it being used in the build log. In my work app, there isn’t one.

I just added it to my app, set it in the settings, re-build and uploaded it and no difference. Here’s the log from that, if it gives any clues?
buildLog.txt (62.0 KB)

Hmm, curious. I see code in EBuild that adds

        lXcent.AddValue('get-task-allow', true, false);

to the entitlement for iOS and tvOS. but this code hasn’t changed since at least February 2018 (probably way before, as the “blame” is for an unrelated cleanup commit), and I have uploaded stuff to TestFlight as recent as a month ago w/o issues, so I’m not sure f that can be the problem…

That entitlements file is used for codesign:

/bin/codesign ... --entitlements "/Users/Jeremy/Library/Application Support/RemObjects Software/EBuild/Obj/TowerVisit-D3F1450B01094450C96DBDC3C7B33F15AF575AD5/Release/Toffee-iOS/Entitlements.sorted.entitlements" ...

you can probably confirm if that file as the setting set to true.

I can try and change this (say, only add this for debug builds; as you will need this for on-device debugging), but I am still curious as to why this has not been an issue before for me, you, or anyone else…

One thing I did change on January 2 this year is that I no longer copy the values form the provisioning profile into the entitlements file (as that was giving me problems very similar to your error, where it would then complain about a mismatch.

Quick workaround to try: the “false” in the above code means it will not replace existing values in the entitlement, only add new ones. Try adding get-task-allow with a value of false to your entitlements file and see if that fixes the issue for now?

If yes, I’ll fix this properly for next week, but this means a new setting for enabling debugging, exposing it in the ice, updating templates for it, etc, so I’d rather hold that until we know it is the issue… :crossed_fingers:t3:

Sorry for the delay, but just had to spend the day taking photos in the snow! Bet it’s a while since you’ve done that!

Anyway, the log I sent was after I added the entitlements file to the project, I hadn’t done that until you mentioned it. I am at home today, so have tried it here, and still had an older fire so used that (.2771 from last September) and had the same result so its unlikely to be the change you mentioned from January.

But, I added the key to the entitlements file and this time it worked! I have an app on the app store (well TestFlight for the moment). My first personal one (I have work ones of course).

Thanks for you help, as ever.

Excellent, I’m happy to hear that!

Cool! lemme know if you need any testers :slight_smile:

Snow… that’s the white stuff right?

Good to know.

Be happy for some feedback, but it’s an app for Bellringers to find nearby towers and log visits and suchlike, so may not exactly be up your street but I’d welcome usability suggestions etc.

Blooming cold :cold_face: too.

Figured it was that. I’d love to have a look, sure, even if there probably aren’t many bells to ring around here!

Yeah, you lost me at cold :joy:

Fab, I’ve sent you an invite. BTW, I did another update after I spotted something, this time with the latest Fire from yesterday and no issues with the addition to the entitlements file, as expected.

1 Like