Application not responding when using new version of RemObjects Elements with Water -,67,69

Hi Team,

If an application have any error then it won’t get build, taking high memory usage and application will be longer responding.
Kindly find below code.

class method Program.Main(args: array of String): Int32;
// add your own code here
writeLn(‘The magic happens here.’);


Hmm, I cant say I can reproduce this :frowning:

this is with stock .2569, the build fails clean and stops.

Can you show mw a screenshot of the Ice when it hangs, with the Build log active? Also, is ebuild.exe still active as a process, in Task Manager, and of so, is it EBuild or Water that is taking up the CPU time and/or memory?

Any chance I could arrange to TeamView inotmyour system to see this happening and debug it locally?


I seen in task manager EBuild takes memory usage high, for now I don’t have screen shot.
If you want to have TeamViewer session we can take it now. So you will get all details.

That’d be appreciated.

Not a good idea to make it public: you should send a private message for this kind of information.

1 Like

I changed my credentials.
Kindly share the email address where I could share the details.

Please find below screen shots for more details.


Oh, VS. you said Water, above. Can you turn on maximum build verbosity under Tools|Options, and retake this screenshot and/or the log output up tot he point where it hangs? also, can you not crop it? thanx!

Can you also look at the Windows Task Manager to see if a “Windows Error Reporting” application is started under the VS instance entry and see if this instance uses the memory and CPU?

1 Like

Find attached output while building the application.
I replaced ************ as my local machine path.

BuildOutput.txt (45.6 KB)

Are you sure it hangs, and doesn’t just take a log time? .NET Core projects literally load in hundreds of references, so resolving these can take some time.

Also, any chance i can see the exact project that fails/hangs?

You have an $IFDEF that’s not closed, is it just an error in the test case or is it when writing it that you have the error?

@mh I just have the case where adding an $ifdef in a class makes VS unresponsive. I must wait before I can add the $endif closing it. The problem, I think, is that the opened ifdef just hides the rest of the source code.

1 Like

Thanks, logged as bugs://85141

Hello. I think I reproduced the hanging, and it seems it connected with the unclosed ifdef. Might be a bug in our parser.
Thanks for the report.

bugs://85141 got closed with status fixed.

Would be good to get the exact test case from both of you, to make sure vika’s fix covers it.

For my case:
Viktoria, you can take the latest version of the web service I give you in the private message.
Open the Fivb.Vis.Model.Server\Application\Log\LogEntry.pas file, line 370 (in the class constructor).
Just delete the line with {$endif} and VS with freeze for a long time.

Thanks Patrick. It doesn’t hang any more with my changes, so I hope I fixed this issue.

1 Like

is this the same issue that I have? Opening a project and not doing anything :

is taking high memory usage and shows “Update File Types for …” (for all project units).
I’ve tried different projects (wasm, java, .net, core) - the same problem. Is this solved?

Could you retest with today’s build? Do you have an unclosed IFDEF in your code? iirc Vika’s fix was specific to that, so your’s might be something else — if so, a testcase would be great.