ASP.net Web Application Template Error

I have tried creating an ASP.net web application with the following settings.

image

which creates a completely blank solution (I’m guessing this isn’t intended).

image

Then clicking on either Project of Debug menus causes the following errors.

Object reference not set to an instance of an object.
at RemObjects.Fire.App.SolutionDocumentWindowController.<get_NamespacesManagerCommand>b__1(Object param)
at RemObjects.Fire.BaseLibrary.RelayCommand.CanExecute(Object parameter)
at MS.Internal.Commands.CommandHelpers.CanExecuteCommandSource(ICommandSource commandSource)
at System.Windows.Controls.MenuItem.UpdateCanExecute()
at System.Windows.WeakEventManager.ListenerList.DeliverEvent(Listener& listener, Object sender, EventArgs args, Type managerType)
at System.Windows.WeakEventManager.ListenerList.DeliverEvent(Object sender, EventArgs args, Type managerType)
at System.Windows.WeakEventManager.DeliverEvent(Object sender, EventArgs args)
at System.Windows.Input.CommandManager.RaiseRequerySuggested(Object obj)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)

Note that this error is on a VM with version10.0.0.2417 but occurs equally on other setups that I have tried.

Thanks, logged as bugs://82876

Daniel,

thanx for letting us know. ASP.NET is (for now) only fully supported in VS, but I’m surprised that the template does not get filtered out for Water and shows. I’ll fix both that and the NRE as part of the above issue; full support for ASP.NET (most likely focused on ASP.NET Core) is a longer-lerm and ongoing issue.

thanx,
marc

Thanks for the update. I’ll give VS a whirl.

1 Like