Autocomplete on TAB; not on SPACE

When I type “If” to start a If-Then-Else construct, the autocomplete pops up, which is ok, because I like to have it show up automatically.

However when I press SPACE it chooses the currently highlighted item in the autocomplete list, which is not what I want. The only thing (afaik) to avoid that is to first pressing ESC and then SPACE, but that’s a bit cumbersome.

Am I missing something here, or is this just the way it works? If that’s the case I would like to see an option to only have autocomplete select an item on TAB and/or ENTER.

That’s a big in CC, that “If” isn’t in the list there. Can I see a concrete test case?

As a general; rule of thumb: CC should always contain everything valid in the current context, and off the current context allows “unknown” identifiers (eg “Dim |”), the CC popup should be “soft”-selected and not insert on space.

Any case where this does not happen is a bug in the CC data, not the fault of “space” accepting that CC.

(That said, you can turn auto-CC off in Preferences). But the goal for CC is to always be correct and this to never happen.

I did some further testing.

It does happen in a For-Next block:

Namespace Test

  Public Shared Class Testing
    Public Sub Test123()
      If 1=1 Then
        For x As Integer = 1 To 100
          // Type If here
        Next x
      End If
    End Sub
  End Class

End Namespace

Also it doesn’t suggest Public/Property direct after Public Class:

  Public Class Testing
    // Start typing Property or Public doesn't suggest it.
  End Class

Logged as bugs://E25381.


bugs://E25381 was closed as fixed.

1 Like