Cannot run or debug .Net Core Winforms App on 32 bit

I tried to run/debug then .Net Core WinForms template on my W10/32 bit OS.
I’ve used the win-x86 switch as given on the other thread.

Running with debug gives

~> Process WindowsApplication86 started, took 0.296.
~> The process failed to start with the following error: System.Exception: Could not find an appropriate version of dbgshim.dll
~> at RemObjects.Elements.Debugger.CLR.CLRDebugEngine.Start()
~> at a.a(String a)

and running without debug gives

Der Befehl “C:\Program” ist entweder falsch geschrieben oder
konnte nicht gefunden werden.

(Seems you’ve missed quotation marks ?)

DebugPane.txt (275 Bytes)
Run.txt (141 Bytes)

WindowsApplication86 1.bugreport.txt (20.8 KB)
WindowsApplication86 (488.4 KB)

Hello Andreas,

Could you check in Water.log (C:\Users\your_name\AppData\Local\RemObjects Software\Elements) what argument you have for "NetCoreDebugShim" when you run your app?

Could be this too needs to change from win-i386 to win-x86, in EBuild.

I’ve uploaded “RemObjects Elements with Water -” to your Personal Downloads, which should fix this and the other issue from last week.

Hi Marc,

the good news:
setting the RuntimeIdentifier isn’t needed anymore and the missig dbgshim.dll
problem seems also be solved.
But: running w/o debug gives the same error (missing quotes ?) and
debugging instantly terminates now without hitting any breakpoint with
~> Process WindowsApplication86 started, took 3.876.
~> Attaching to 6284
~> Process WindowsApplication86 terminated with exit code -1. Ran for 2.009

Best regards