Can't find resource for bundle


(Claudio) #1

I updated to the last version of Fire (, when I try to run any application in debug (even a just created application or an Element sample project), on my real Nexus 5X device, I get the following error inside the Fire IDE:

An exception occurred in, thread 0002 ()

Type: java.util.MissingResourceException


Can't find resource for bundle$ResourceTable, key en_US

Call Stack:

0000000000000000, , , UResourceBundle.handleGetObjectImpl(), 
0000000000000000, , , UResourceBundle.handleGetObject(), 
0000000000000000, , , ICUResourceBundleImpl$ResourceTable.handleGetObject(), 
0000000000000000, , , ResourceBundle.getObject(), 
0000000000000000, , , ResourceBundle.getString(), 
0000000000000000, , , ULocale.lookupLikelySubtags(), 
0000000000000000, , , ULocale.createLikelySubtagsString(), 
0000000000000000, , , ULocale.addLikelySubtags(), 
0000000000000000, , , LocaleList.getLikelyScript(), 
0000000000000000, , , LocaleList.matchScore(), 
0000000000000000, , , LocaleList.findFirstMatchIndex(), 
0000000000000000, , , LocaleList.computeFirstMatchIndex(), 
0000000000000000, , , LocaleList.computeFirstMatch(), 
0000000000000000, , , LocaleList.getFirstMatchWithEnglishSupported(), 
0000000000000000, , , ResourcesImpl.updateConfiguration(), 
0000000000000000, , , Resources.updateConfiguration(), 
0000000000000000, , , Resources.updateSystemConfiguration(), 
0000000000000000, , , ResourcesManager.applyConfigurationToResourcesLocked(), 
0000000000000000, , , ActivityThread.handleBindApplication(), 
0000000000000000, , , ActivityThread.-wrap2(), 
0000000000000000, , , ActivityThread$H.handleMessage(), 
0000000000000000, , , Handler.dispatchMessage(), 
0000000000000000, , , Looper.loop(), 
0000000000000000, , , ActivityThread.main(), 
0000000000000000, , , Method.invoke(), 
0000000000000000, ,, ZygoteInit$, 
0000000000000000, ,, ZygoteInit.main(), 

If I try to run the application in Release, the application on my phone hangs on the “Waiting for debugger” pop-up indefinitely and on Fire appears the message:

Could not deploy or debug.

The process failed to start with the following error: Starting: Intent { }:

I tried also on an emulated device, and it hangs on the “Waiting for debugger” pop-up forever, both in Debug and Release.

(Claudio) #2

I can test my application only by doing “Deploy w/o Running” on either Product or Debug menu.

(marc hoffman) #3

i’m afraid i’ll need some more details on that. i can run/debug my “File|New Android App” project on my 6P just fine, and don’t get this error. can you send me your project?


(Claudio) #4

Hi Marc,
you can try also with a just cloned FirstAndroidApp sample.

Yesterday tests on my Nexus 5X and emulator were both on 7.1.1

Today I did more tests: on a Samsung S4 with Android 5.0.1, run the application in the normal way works fine.

(Claudio) #5

More tests: on emulator, I tried the Nexus 5X 5.0.2 and 6.0, and it hangs waiting on debugger.

I tested on a emulated Pixel 6P with 5.0.2, and it works!!!
So, the problem at the moment seems to be only on Nexus 5X, both real or emulated.

(marc hoffman) #6

Hmm. I’m tempted to consider not a problem with the Elements build chain then; i don’t know what is, but i’d think if there’s something that Elements does wrong wit packaging the app WRT that, the problem would not manifest only on the one device type, like that.

That said, i’ll have a look at it with a 5X emulator later, myself (i don’t have a 5X hardware, just a 6P).


(marc hoffman) #7

Sorry to say, i can deploy and run my app on the 5X emulator just fine :frowning:

(Claudio) #8

Thanks Marc, maybe a dirty configuration of Fire? Is there a way to
"factory reset" the IDE, or something like that? Do you think may help?

(marc hoffman) #9

There’s nothing in Fore that could get “dirty” in that regard, really. Try completelty cleaning the project (delete ./bin and /obj), but aside form that, there’s no global state that could remain corrupted.

One idea: send me your app project and the finished .apk, i can see what happens if i run that here, and compare.


(Claudio) #10

Hi Marc,
making more tests I realized that I am facing two different problems:

  • the missing resource in the title of this thread
  • the “Waiting for debugger” problem

The first one happens only on my real Nexus 5 device on debug, and clicking on continue on the Fire popup, it works.

The second one happens very often with several device, both real and emulated.

At the moment I can workaround with the “Deploy w/o running” feature (very handful). When I understand better the problem, I will back to you.

Thanks Marc

(marc hoffman) #11

Ahh, then this isn not a bug, just an expected (and caught) exception. remember that Java and Android throw a whole bunch of exceptions at startup, they get caught and the app keeps running, but if a debugger is attached, you will of course see those. Fire is programed to ignore a few common ones (and uses the user is not likely to want to see), but I’m hesitant to add “missing resource” to the list of ignored exceptions, because that could very well be raised due to a legitimate bug, in other scenarios.

As for the “waiting for debugger” issue, i have had another user report that too, for the it was ties tom a specific (emulator) device. do you see the same — i.e., the same set of devices always works, and the others always fail? or is it more random)? FWIW, the other user reported seeing this from both Fire and VS, so its likely a more general issue with the debug engine or the on device debugger, than a bug in Fire. But we’ll need to try and reproduce this on our end. If you can see any system in what devices fail to attach the debugger, that might help us reproduce the issue.


(Claudio) #12

As for the “waiting for debugger” issue, i have had another user report that too, for the it was ties tom a specific (emulator) device. do you see the same — i.e., the same set of devices always works, and the others always fail? or is it more random)?

I observed this behaviour: in some devices never works (eg Nexus 5X 7.1.1 emulated); in other devices sometime works, sometimes not (eg. Nexus 6p 5.0.0 emulated, I just run twice the very same code, the first shot was ok, the second hung). On my real Nexus 5X 7.1.2, it seems to always work (but I didn’t run many times).

(Claudio) #13

Good news: the problem “waiting for debugger” seems to be correlated with Android Monitor of Android Studio. If the Android Monitor is set to the same device and the same application, randomly it takes the priority over Fire.

It seems reasonable, and not a big deal at all. Maybe the other user can confirm this correlation.