"Clear Search Term" keyboard shortcut not working (CTRL + SHIFT + ALT + F)

The “Clear Search Term” keyboard shortcut (CTRL + SHIFT + ALT + F) in Water stopped working for me as of .2439 and also does not work in .2441. All other keyboard shortcuts appear to work fine still.


I noticed that too, not sure if it ever worked. It’s bound correctly as far as I can tell, it just doesn’t fire :(. WPF’s command routing system can be such a mess to debug when the obvious stiff fails… I’ll have a another look to see if i can find what’s wrong…

case in point:

        <KeyBinding Key="F" Modifiers="Ctrl" Command="{Binding FindCommand}"/>
        <KeyBinding Key="F" Modifiers="Ctrl+Shift" Command="{Binding FindInSolutionCommand}"/>
        <KeyBinding Key="F" Modifiers="Ctrl+Shift+Alt" Command="{Binding ClearSearchTermCommand}"/>

:(. Beats me why it doesn’t trigger…

It definitely worked on my machine until recently (fairly certain it was .2439), I use it constantly :grimacing:


odd. I remember it not working for mw quite a while ago (but I don’t use Water that much day to day, as I’m mainly on the Mac), and nothing changed there. I’m wondering if anything on the OS level might capture the shortcut before it even gets to Water, ands if the conditions for that change due to something we currently are not aware of? That said, Google digit reveal this too be any kind of ‘default’ system shortcut…

I’ll check if others here at RO that use Windows more see or don’t see the same issue…

Oh: what’s your locale? iirc in some locales Ctrl+Alt is there same as Alt-Gr. i vaguely recall fixing some other shortcut todo away with the combo…

Yup, February 10:

Water: Avoid Alt+Ctrl+Letter keyboard shortcuts because it’s same as AltGr and breaks on non-US keyboards. Sigh.

I had to change Ctrl+Alt+B & co to Ctrl+Alt+Shift+B — though that seems to be the reverse issue, since that new combiner’s worked, and just the version w/o Shift was problematic… Weird.

English-US. I did also just realized that I had a Windows update a few days ago that may have triggered it. I don’t recall the exact timing, but it was around the time I noticed it.

Strangely enough, that shortcut still works for me, even though it uses the same Ctrl+Alt+Shift sequence…

Yeah, same here.

Just for info: https://superuser.com/questions/1445551/what-does-ctrlaltshiftf-key-combination-in-windows-10-pro-version-1903-do

1 Like

That explains it :(.

1 Like

You’ve got to love Windows :roll_eyes:

Tell me about it…