Convert Website to Web Application

Hi there,

I need to convert a website to a web application.
All the articles about it do not work with Oxygene.
The “Convert to Webapplication” menu entry just does not appear.

Caan you give me a hint a how I can do this with Oxygene?

Im Using VS 2015. Website is ASP:NET 4.61

Cheers Marcus

You probably need to create the web application using a template and add all the files yourself.

What I have done (well, tried to do)

Changed CodeFile to CodeBehind, added namespace to Inherit.
When I copied the files into the template I have got thousands of errors that filename is too long as Oxygene creates copy(1).copy(2).copy(3)………… for nearly each file.

And it is nearly impossible to create the needed xxxx.aspx.Designer.pas files by myself.
The manually created ones are not displayed and accepted within the project.
And it would take ages to get all the components in .aspx declared manually.

So, you tell me, it is not possible to convert website to webapplication with Oxygene sources, as it can be done without Oxygene?

I’d expect so too, yeah.

Hmm. they sounds like a bug in VS. Do you have concrete steps that show this?

The types of files should be the same for a web site and a web application, “all” that changes is the build model. Why do you need to create to change these files, just as part of switching from site to app?

Just moved the original webform1.aspx with the mouse a bit up and down, result:

image

Without designer.pas VS does not find controls on aspx:

I tried it manually, but it does not work:

Thanks, logged as bugs://84124 — for the copy(1).copy(2).copy(3) files

Another one:

I have converted it manually now:

  1. New Web Application
  2. For each webform in website created new webform in web-api
  3. Copied the contents of old .aspx and old .pas into new webform
  4. 24 hours and many VS 2015 crashes later it worked.

When I now change something, latest after 10 Min. VS freezes:

image

using latest beta from last friday

went Back to version .79, now this comes:

Yep, I believe this was a regression in .2479 that has since been fixed. Workaround, if you must stay on 2479, set it to 0 instead f False.

n

Ok.
.79 was very stable. Had to go back because of the VS freezing with latest beta. In which file I have set it to 0?

<Optimize>0</Optimize>

to replace

<Optimize>False</Optimize>

in your .elements file.

But iirc the freezing other people have also reported is caused by the VS 16.5 update, but by an Elements change… We’re working on that.

Hi Marc,

works, thanks.

I keep you informed if VS still freezes in this particular project also with .79

Cheers

Marcus

1 Like

By the way, I am working with VS 2015 Update 3.

So Update to 16.5 cannot be the reason

All Problems gone after going back to .79

No freezing, a lot faster in working an compiling

Curious.