"Could not determine path for executable" when trying to debug WebAssembly


(Trevor Jay) #1

Hi everybody!

When I try to debug a completely unmodified "Module (WebAssembly) project generated directly from the template, Chrome does not launch. Instead, I get a “Could not determine path for executable” error.

To give some background: I’m trying to evaluate Elements for a couple of projects. I was poking around the “Module (WebAssembly)” template project with the last version of Fire without any problems (Chrome debugging worked fine). While using the IDE I was asked to update Fire to the latest version, which I did. Since then instead of Chrome debugging working I get the “Could not determine path for executable” error instead.

Things I’ve tried so far:

  1. Creating a fresh project from the template: same error
  2. Reinstalling Fire: same error
  3. Deleting all RemObject related data in my ~/Library and then reinstalling Fire: same error
  4. Opening Chrome first: same error
  5. Downloading and upgrading to latest Chrome: same error

Can anyone give me any insight into this problem? From my explorations so far, I’m really liking what I’ve seen of Fire. However, I obviously can’t pitch Elements without debugging support though. :wink:


(Carlo Kok) #2

This is fairly odd, seems to have regressed in the previous betas. My apologies, we’ll take look and let you know when it’s fixed.


(RemObjects) #3

Thanks, logged as bugs://81732


(Trevor Jay) #4

Thanks! To be specific, I’m using version 10.0.0.2351. Is there somewhere I can find the older version to download?


(marc hoffman) #5

My apologies, this should be fixed now, I can send you a new Elements build later today, once we’ve conformed the fix.


(Trevor Jay) #6

That’s an insanely quick turnaround even for a regression. Thanks and regards.


(marc hoffman) #7

Trevor,

I’ve uploaded a new build of the Elements compiler for you to personal downloads. Please check out https://docs.elementscompiler.com/Fire/Setup/Mac/ExternalCompiler/ for instructions on how to make Fire use the externally installed compiler (the next full Fire build will of course have that fix, as well).

thanx,
marc


(Trevor Jay) #8

I’m downloading now. I’ll let you know as soon as I have it configured and tested.


(Trevor Jay) #9

I can’t speak for anyone else, but that completely eliminated the regression for me. Many many thanks. This is exactly what I needed to put together a demo (and with a great support story to boot).

Keep up the great work! It’s very appreciated.


(marc hoffman) #10

Glad to hear!


(RemObjects) #11

bugs://81732 got closed with status fixed.