DA Schema modeler GUI crashes

With RemObjects v9.7.115.1441 I get a lot of crashes in the IDE.
Multiple AV popups in module RemObjects.DataAbstract.Unmanaged.dll

At present I cannot create DA fields and hence I am completely stuck

How can this be solved?
I already restarted delphi 10.3.2 but this did not solve the issue.
It is unclear to me why I have this now and not before/always

Please provide me with a fix TaakService_Impl.pas (23.3 KB) taakservice.zip (7.6 KB)



Can you retest this issue with the latest 10.x build, pls?

Edit: Can you attach DDL script for this table, pls?
you can send it directly to support@ if you want to keep it privately

Is v10 fully compatible with v9?
It is quite an effort to migrate our team to a new version.
We use DevArt SDAC still use DA3 and typically have to install some patches manually.

We do not use DDL files? we have our schema in the delphi DFM files.
What do you want me to send you exactly?

yes, it is compatible

I need data description language (DDL) script for creating this table in database.
you may use some unsupported datatypes in this table so it may cause errors in DASM.


It crashes as soon as I open the DA schema modeler
I have not yet selected a table yet

This is one table definition
CREATE TABLE [dbo].[berichten](
[ber_primkey] [int] NOT NULL,
[ber_tijdstip] [datetime] NOT NULL,
[ber_tekst] [text] NULL,
[ber_prioriteit] [int] NOT NULL,
[ber_status] [int] NOT NULL,
[ber_afzender] varchar NULL,
[ber_berichtbron] varchar NOT NULL,
[ber_gelezen] [bit] NOT NULL,
[ber_opties] [int] NOT NULL,
[ber_UserID] [int] NOT NULL,
[ber_bronsubtype] varchar NOT NULL,
[ber_enkeltitularis] [bit] NOT NULL,
[ber_bestemmelingfilter] varchar NOT NULL,
[ber_bge_primkey] varchar NULL,

if you launch Schema Modeller manually (not from Delphi IDE), will be these errors reproduced?

can you check that these files have the same modified date?

  • DASchemaModeler7.exe
  • DASDACDrv.dad
  • RemObjects.DataAbstract.Unmanaged.dll

note: they are located in C:\Program Files (x86)\RemObjects Software\Data Abstract (Common)\Bin folder.

FYI: Meanwhile I have tried to install V10 but I get errors in the generated RO source files
(regenerating the strongly typed access units does not solve the errors)
Is V10 still compatible? Can it be made compatible?

[dcc32 Hint] uDANativeDatabaseAccessSupport.pas(236): H2164 Variable ‘us’ is declared but never used in ‘TDANativeDatabaseAccess_Dataset.GetNativeFieldData’
[dcc32 Hint] uDANativeDatabaseAccessSupport.pas(237): H2164 Variable ‘temp’ is declared but never used in ‘TDANativeDatabaseAccess_Dataset.GetNativeFieldData’
[dcc32 Error] DASchemaClient_Intf.pas(17989): E2003 Undeclared identifier: ‘IROStream’
[dcc32 Error] DASchemaClient_Intf.pas(18023): E2005 ‘IROStream’ is not a type identifier
[dcc32 Error] DASchemaClient_Intf.pas(18040): E2007 Constant or type identifier expected
[dcc32 Error] DASchemaClient_Intf.pas(18061): E2005 ‘IROStream’ is not a type identifier
[dcc32 Error] DASchemaClient_Intf.pas(18094): E2005 ‘IROStream’ is not a type identifier
[dcc32 Error] DASchemaClient_Intf.pas(41852): E2005 ‘IROStream’ is not a type identifier
[dcc32 Error] DASchemaClient_Intf.pas(42117): E2005 ‘IROStream’ is not a type identifier
[dcc32 Error] DASchemaClient_Intf.pas(42174): E2007 Constant or type identifier expected
[dcc32 Error] DASchemaClient_Intf.pas(42502): E2005 ‘IROStream’ is not a type identifier


the first 2 hints were already fixed.
have you recreated _Intf after installing v10 ?
IROStream is located in uROStream.pas

I have recreated the _intf files but they generate a pas file that does not have uROStream in the uses list.
See the attched file.DASchemaClient_Intf.pas (8.2 MB)

Yes, they have the same date
29/05/2019 14:23 4 877 824 DASchemaModeler7.exe
29/05/2019 13:55 1 074 DASchemaModeler7.exe.config
29/05/2019 14:23 5 061 632 DASDACDrv.dad
29/05/2019 14:23 5 859 328 RemObjects.DataAbstract.Unmanaged.dll
29/05/2019 13:55 108 RemObjects.DataAbstract.Unmanaged.ini

FYI: I have reinstalled the 9.7 and now it does not fail systematically anymore.
But maybe we can still see what would be needed to make v10 work.


Can you reproduce AV in RemObjects.DataAbstract.Unmanaged.dll when DA v10 is used?


as a temporary workaround, add uROStream into uses section of DASchemaClient_Intf.pas.

as a full workaround: update uDASchemaUnitsGenerator.pas and add uROStream at 312 and 668 lines and recompile DA_IDE package. (the lines are valid for DA v10.0.0.1453)

Thanks, logged as bugs://83259

bugs://83259 got closed with status fixed.

Thanks, when will the next v10 be released?
I will try to migrate to v10 then

we usually release DA v10 at Wednesday biweekly