Data Abstract project wizard issue


(brian71us) #1

I downloaded the latest version of Data Abstract this morning to create a new project. When I went through the project wizard to create a Data Abstract server I clicked the top check mark to un-check all of the pre-selected tables. Then I checked just the two tables that I actually wanted.

The project that the wizard created had all of the tables selected instead of just the two that I wanted and there are hundreds of tables in this database.

Now I’m finding that the Schema Modeler is very slow with this many tables and it keeps crashing on me when I try to clean it up.

Visual Studio 2017
Data Abstract

(antonk) #3


Unfortunately I was not able to reproduce this issue locally, so I’ll; need to ask some additional information.

Have you also un-checked the Views node? Views are also represented as Schema Tables in the generated Schema.

If so, then could you send to support@ a video or a set of screenshots of every Wizard step and the database structure script (we’ll need this info to reproduce the issue locally)

How exactly does it crash? Do you have any stacktrace log (Schema Modeler should display a window containing a stacktrace when it crashes)

Thanks in advance

(brian71us) #4

When I uncheck views and stored procedures it does work ok.

When it crashed it just went “poof!” and was gone. No stack trace or anything.