Debugging console apps (2601)


I cant seem to debug either island or toffee console apps. When I launch a island mac os console app in Fire I get

~> System.NullReferenceException: Object reference not set to an instance of an object
~>   at RemObjects.Oxygene.CoreDebugEngine.DebugEngine.CreateDebugEngineFromStartInfo (RemObjects.Elements.CrossBox.DebuggerStartParameters aStartInfo) [0x0004c] in <ed45a84686a74c15a5ea4dbb441e0d2d>:0 
~>   at RemObjects.Oxygene.CoreDebugEngine.DebugEngine.CreateDebugEngineFromStartInfoJson (System.String aStartInfo) [0x0000c] in <ed45a84686a74c15a5ea4dbb441e0d2d>:0 
~>   at (wrapper native-to-managed) RemObjects.Oxygene.CoreDebugEngine.DebugEngine.CreateDebugEngineFromStartInfoJson(string,System.Exception&)


Hmm, I debugged one just now when I sent you that screenshot in the other thread (and I retested Island and Toffee just now)… very strange. Is there anything else in the Build Log or the Activity (⌘⇧9) window?

is this with any app (say, new from template), or a specific one(s)?

Sorry I made a mistake. I forgot to install the latest mac zip. After I did that and restarted Fire it worked ok.

Hmm. Still curious; this should not matter. So you were using an old external compiler (what version?) with 2601 Fire? This should not affect debugging in any way…

I copied the new zip to my elements folder but then forgot to run sh.install. I was also using the internal compiler at the time.

I restarted Fire, tried debugging and it was ok.

Ok, weird. I dont see how this could have caused this, but if all works now, lets just call it a fluke :wink: