Debugging crashes Water

Hi,
Just encountered Water crashing while debugging with Step over or Step into.
No exception shown, is just freezes for 10 sec. and the Water closes down with no further messages.
It disappears as when you close a process in the task manager.
I retried a couple of times with the same result, as well as rebuilding the projects.

Using version 10.0.0.2609.

Exception from Windows Event Viewer:

Program: Water.exe
Framework-version: v4.0.30319
Beskrivelse: Denne proces blev afsluttet pga. en ubehandlet undtagelse.
Undtagelsesoplysninger: System.AccessViolationException
   ved CORDBLib.ICorDebugEval2.CallParameterizedFunction(CORDBLib.ICorDebugFunction, UInt32, CORDBLib.ICorDebugType[], UInt32, CORDBLib.ICorDebugValue[])
   ved RemObjects.Oxygene.CoreDebugEngine.CLR.CLRDebugEngine.CallValue(RemObjects.Oxygene.CoreDebugEngine.EvaluatorValue, RemObjects.Oxygene.CoreDebugEngine.StackFrameInfo, RemObjects.Oxygene.CoreDebugEngine.EvaluatorMember, RemObjects.Oxygene.CoreDebugEngine.EvaluatorType[], RemObjects.Oxygene.CoreDebugEngine.EvaluatorValue[])
   ved RemObjects.Oxygene.CoreDebugEngine.CLR.CLRDebugValue.GetSubValuesForType(RemObjects.Oxygene.CoreDebugEngine.StackFrameInfo, RemObjects.Oxygene.CoreDebugEngine.EvaluatorType, CORDBLib.ICorDebugType, System.Collections.Generic.List`1<RemObjects.Oxygene.CoreDebugEngine.EvaluatorValue>)
   ved RemObjects.Oxygene.CoreDebugEngine.CLR.CLRDebugValue.GetMembers(RemObjects.Oxygene.CoreDebugEngine.Evaluator)
   ved RemObjects.Fire.ProjectSystem.DebugEvaluation+<>c__DisplayClass0.<fillChildrenWithCallback>b__0()
   ved RemObjects.Fire.BaseLibrary.SBLSingleThreadedQueue.processQueue(System.Collections.Generic.List`1<RemObjects.Fire.BaseLibrary.SBLSingleThreadedQueueTask>)
   ved RemObjects.Fire.BaseLibrary.SBLSingleThreadedQueue.main()
   ved System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   ved System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   ved System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
   ved System.Threading.ThreadHelper.ThreadStart()

And this one:

Navn på program med fejl: Water.exe, version: 10.0.0.2609, tidsstempel: 0x6042630b
Navn på modul med fejl: mscordbi.dll, version: 4.8.4300.0, tidsstempel: 0x5f7e6041
Undtagelseskode: 0xc0000005
Forskydning med fejl 0x00000000000414db
Proces-id 0xc620
Programmets starttidspunkt 0x01d7141afaa1b57f
Programsti: C:\Program Files (x86)\RemObjects Software\Elements\Bin\Water.exe
Modulsti: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\mscordbi.dll
Rapport-id: 5c3c1cbb-7a42-4b97-a8d5-93421d2fba4d
Fuldt navn på program med fejl: 
Relativt program-id for program med fejl: 

And finally:

Fejlbucket 1460340315157319746, type 4
Hændelsesnavn: APPCRASH
Svar: Ikke tilgængelig
Cab-id: 0

Problemsignatur:
P1: Water.exe
P2: 10.0.0.2609
P3: 6042630b
P4: mscordbi.dll
P5: 4.8.4300.0
P6: 5f7e6041
P7: c0000005
P8: 00000000000414db
P9: 
P10: 

Tilknyttede filer:
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERAE49.tmp.dmp
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERB270.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERB2B0.tmp.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERB2AE.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERB2ED.tmp.txt

Disse filer er muligvis tilgængelige her:
\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_Water.exe_3b25a42babd82fc84ee1d66ce299fd656577588_3588d033_9deaa899-e670-49c3-b04c-358218504248

Analysesymbol: 
Søger efter løsning igen: 0
Rapport-id:5c3c1cbb-7a42-4b97-a8d5-93421d2fba4d
Rapportstatus: 268435456
Hashbucket: e38c4dc5b1e3c8f334442bc788225042
Cab-guide: 0

Is this with any specific project/steps? What project platform?

thanx,
marc

Thanks, logged as bugs://85696

Nevermind that part, I see from the calls track, that it’s CLR…

Hello!

Could you provide us with a testcase reproducing the problem, please? Describe also what steps should be done to get it.

Thanks.

Just any project and run with debugging. It then freezes and terminates.

But I will have to try again, now that I have had a couple of updates, since I tried last time.

I will get back, once I have had the time to reproduce.

Just trust me when it say it’s never that easy. We use Elements, Fire and Water every day. if something this fundamental was “always broken”, chances are 99% we’d notice and not ship it, like that. :wink:

Thats right, I can’t that it is any project in Water, just the projects in the solution I was building.
I will find a reproducible project and get back to you.