Deploy to device error

I’m having trouble with latest Fire deploying to any device. Can’t work out why (I’ve resorted to putting it through test flight to get it onto the device). I can do it with Xcode with the same profile/certificate so I’m sure it’s not that. I’m getting this:

Device has been detected
Installation progress: 0% PreflightingTransfer
Installation progress: 5% TransferringPackage
Error: AMDeviceTransferApplication | e8000001 (-402653183)
DetailedError: An unknown error occurred. (kAMDUndefinedError)
Deployment of app bundle failed.

Any ideas?

Hm, nothing really has changed here in ages… Anything more detailed in the Console? e8000001 is pretty generic, and I;ve never seen installs fail at 5% — usually its 70% or 95% of there’s a real problem with the binary, say.

It’s probably not a new issue as I’ve not tried to deploy to a device for a bit.

I see in console this:

default 13:25:19.077538+0000 crossboxhelper preflight_transfer (thread 0x10e394dc0): Could not stat /Users/jeremyknowles/Documents/Documents – Jeremy’s iMac (home)/Github/hcdbuddy2/Bin/Debug/iOS/ No such file or directory

I can see the file it’s referring to, so it definitely exists. There are some odd characters in that string though.

is that really the path? that looks quite mangled.

is that the local Console or the phone’s?

Yes, there’s an apostrophe in the computer name. Maybe I’ll rename it, but it’s always been there.

That’s the local, The copy missed the bit that it was a crossbow helper message (probably should say start rather than stat)

Maybe i’m missing something but there’s a lot for garbage in the path name that I se here than just an apostrophe?

fwiw, neither “preflight_transfer” or “Could not stat” are strings crossboxhelper itself emits, so not sure where thats coming from, but by money is on the error being “correct”, that the path it tries to access somehow isn’t right.

I’m also betting it has nothing to (directly) to do with the real error (aside from that it might be caused by the same toor cause — the bad path)

Check the device’s log, it’ll haver the real error details.

Can you also post anything in the build log before “Device has been detected”, especially the line with the call to crossboxhelper, and possibly. screenshot that includes it too?

Solution ‘hcdBuddy2’ built successfully.
Running /Applications/ --deploy 376cec5c3c8f09cbd6e1e8062d027b573fe1538f “/Users/jeremyknowles/Documents/Documents – Jeremy’s iMac (home)/Github/hcdbuddy2/Bin/Debug/iOS/”
RemObjects Elements CrossBoxHelper 1.42: Deploy to device

Waiting for device: 376cec5c3c8f09cbd6e1e8062d027b573fe1538f
Device has been detected

Can’t see anything showing an error. Any of these (I cleared the log before trying to deploy and this is what the log on the iPad shows):

I’ve solved it, by which I mean I have got it to work. When I delved into the path, on this mac (on which I have way too many photos), I moved my documents to be on the iCloud drive, so /Users/jeremyknowles/Documents/Documents – Jeremy’s iMac (home) is actually iCloud Drive/Documents/Documents – Jeremy’s iMac (home)

I have renamed the folder in documents now to remove the apostrophe so now the path is /Users/jeremyknowles/Documents/Documents iMac (home)

It now deploys.

Curious. sop you had a project from iCloud Drive open, but the file path Fire was seeing (and passing to crossboxhelper) was not the path to the actual file on disk?

I guess that’s right, but macOS seems to map the path to be what I’d expect. When I updated to Catalina, I opted to have my docs folder to the cloud drive. I think it was the hyphen and/or the apostrophe in the path name that made it go wrong, since as I removed those it works fine now. Curious, maybe just this topic will be enough for anyone else to find to resolve an issue in the future as I would have thought it would have come up before if it was a common problem.

1 Like

I’ll try to repro this myself later, jic.