Editor doesn't show first line / scroll problem

When I open a code file the first line is hidden:

I only can bring it back when scrolling to the top with the mouse. Using the keyboard doesn’t work; the cursor will be on the first line, but the first line is still hidden.

NB: Tested on macOS Monterey.

Do you by any chance have “always show scroll bars” turned on? If so, that is a known issue that was reported before that I’m investigating but have not been able to solve yet.

A workaround would be to turn that option off in System Preferences.

Yes that does solve it. Don’t mind to have this setting always turned on, so for me it’s solved.

Cool. I still wanna solve it eventually, but at least then it’s less urgent :slight_smile: