Elements/Oxygene disappeared from Visual Studio 2017

visual-studio
oxygene

(Matt Robertson) #1

I am 3 days into my 30 day trial period using Oxygene in Visual Studio 2017. I restarted my laptop this morning, and Oxygene has disappeared without a trace from Visual Studio. I cannot create new Oxygene projects, open existing Oxygene projects (in both cases I get an error saying the application/template is not installed), and the Elements submenu is missing from Visual Studio settings. I tried re-installing Elements - the install was successful but still no Elements in Visual Studio. What am I missing?

In my original installation I downloaded Visual Studio 2017 from Microsoft’s website and then installed Elements, unchecking the box to also install Visual Studio 2015.


(marc hoffman) #2

That’s very curious. I’ll get someone form your VS team to get back to you for somethings to check, ASAP. There should bene a couple log files from VS that might tell us whats going wrong.

My sincerest apologies for this inconvenience.

—marc


(Matt Robertson) #3

I reinstalled with the option to install Visual Studio 2015 and it seems to be working in 2015 now, so it’s not a pressing issue for me anymore. Still happy to help by sharing any log files or anything you need.

Matt


(viktoriad) #4

Hello Matt,

VS2017 integration is done via VS extensions. Could you please open VS2017 and check next:

  1. Open Tools => Extensions and Updates menu
  2. Find next items among extensions:
  • RemObjects.Oxygene.VisualStudio.Project.2010
  • Oxygene Editor extension
  • CrossBoxUI
    That 3 extensions must be there, in the list, and active (not disabled).

Also, do you have any error dialog window when starting VS or opening Oxygene project? Could you please check the ActivityLog.xml file if it has any errors connected with RemObjetcs. The file is located in the next path:
C:\Users\ <YourUserName>\AppData\Roaming\Microsoft\VisualStudio\<15>

Thanks in advance.


(Matt Robertson) #5

That was it - CrossBox was disabled. When I enabled it, Visual Studio detected Elements again. When I tried to build & run my Android app, however, Visual Studio crashed (a consistently recurring problem - I’ve not had a successful build yet). Now upon restart, all of the extensions you listed are enabled but the Solution Explorer shows “The application is not installed” in place of my project files.


(Matt Robertson) #6

To give more context to this issue, Visual Studio (2015 & 2017) crashes after displaying the ADV Loading message. Upon restart VS shows a message saying “A previous session terminated unexpectedly. Disabling extension ‘CrossBoxUI 2.0’ might help prevent similar issues.”

That was what led to the initial problem - I followed this prompt and disabled CrossBox.


(marc hoffman) #7

Ah, that at least explains the original problem. Now we need to figure out why it crashes :wink:


(viktoriad) #8

Hello Matt,
just to confirm - you are trying to create and build Android app, and building the Android app crashes?
Does the same situation happens for simple Oxygene .NET application? E.g. if you create an Oxygene .NET Console app and try to run it - does it crash the Visual Studio?
Also could you please attach empty VS studio to instance where Android app is opened, set “Tools => Options => Debugging => uncheck Enable just my code option” and set Debug => Windows => Exceptions => show all CLRE. After it switch to Android VS instance and reproduce the crash. Here it should show the exception and callstack. Please copy that callstack here.

Thanks in advance.


(Matt Robertson) #9

@viktoriad Thanks. Yes, VS crashes when I try to run an Android app on a virtual device. I was able to build and run a .NET application successfully. I turned on the debug settings you mentioned, but do not know how useful they are - VS completely crashes and the system restarts it.

I select my Virtual Device in the Crossbox menu, press the Run button, the “Launching Virtual Device” dialog displays, and then a Windows system dialog appears on top of that saying “Visual Studio 2015 has stopped working…” And Windows restarts Visual Studio.

I did get an option to debug VS on restart this time however. This is the callstack.

> mscorlib.dll!System.IO.Path.Combine(string path1, string path2, string path3) Unknown
RemObjects.Elements.VisualStudio.CrossBoxUI.14.dll!RemObjects.Oxygene.VisualStudio.CrossBoxUI.LaunchAvdWindow.Launch.AnonymousMethod__0(object param0) Unknown
mscorlib.dll!System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(object state) Unknown
mscorlib.dll!System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, object state, bool preserveSyncCtx) Unknown
mscorlib.dll!System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, object state, bool preserveSyncCtx) Unknown
mscorlib.dll!System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem() Unknown
mscorlib.dll!System.Threading.ThreadPoolWorkQueue.Dispatch() Unknown
mscorlib.dll!System.Threading._ThreadPoolWaitCallback.PerformWaitCallback() Unknown

(viktoriad) #10

Matt,

It sounds like the AndroidSDK is not installed on your machine properly. Somehow Oxygene cannot find the path to it. If the AndroidSDK is installed, please check its path here:
Tools => Options => Projects and solutions => RemObjects Elements => Java settings. Check the Adroid SDK path there, if it is assigned or not. If it is empty, select the proper path. That should fix your crashing VS and give you ability to run and debug Android app.
Also please, let me know if that was it and if that helped you. I will add extra check on AndroidSDK property too so the VS would not crash but shows proper error.

Thanks in advance.