Error compiling a project with Elements


We’re facing a problem compiling our project.

Weve just installed the following version of Elements and Data abstract, some environments are ok, while others arent.

Erro (E221) Error while processing licenses: System.IO.FileNotFoundException: Não foi possível carregar arquivo ou assembly ‘RemObjects.Everwood.Live.Base, Version=, Culture=neutral, PublicKeyToken=3df3cad1b7aa5098’ ou uma de suas dependências. O sistema não pode encontrar o arquivo especificado.
Nome do arquivo: ‘RemObjects.Everwood.Live.Base, Version=, Culture=neutral, PublicKeyToken=3df3cad1b7aa5098’
em System.ComponentModel.LicenseManager.CreateWithContext(Type type, LicenseContext creationContext, Object[] args)
em bj.a(Stream a, String b, String c, String d)

AVI: o log de associações de assembly está desativado.
Para ativar o log de falhas de assembly, defina o valor do Registro [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) como 1.
Observação: há alguma penalidade para o desempenho associada ao log de falha de associação de assembly.
Para desativar esse recurso, remova o valor do Registro [HKLM\Software\Microsoft\Fusion!EnableLog]. dxserver C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\MSBuild\RemObjects Software\Elements\RemObjects.Elements.Echoes.targets 70

What could we do to detect exactly the problem?

System config
OS: Windows 10
Visual Studio 2019 Version: 16.10.2
RemObjects Data Abstract for Delphi, Server Edition -
RemObjects Data Abstract for Water and Visual Studio, Server Edition -
RemObjects Elements with Water -

Thank you!

Can yu make sure the issue persists with the very latest versions of DA and Elements?


I don’t think is related with latest version, because most environments worked fine, just some are with this problem.

Thank you.

We have already reinstalled every package again

Is there any order needed to follow?

Thank you.


try this order:

  • Elements
  • Data Abstract

Note: Data Abstract .1553 was created after Elements .2785

Edit try to uninstall all RemObjects products and install them from scratch.
we don’t ship RemObjects.Everwood.Live.Base.dll since last year

Reinstalled everything from scratch

same error.

Following this order:

  • Elements
  • Data Abstract

Thank you,


I think, you have installed Hydra 6.4 sometimes.
Can you uninstall it or install modern version of Hydra, pls?


just Hydra?

Thank you!

Uninstalled just Hydra, the problem remain…

I’ve installed

1 - Elements
2 - Data Abstract for .Net
3 - Data Abstract for Delphi

Obs: These are the version lastest version released when we started testing November the 3rd.


odd. lets cleanup your pc.
for this:

  • uninstall Elements
  • uninstall DataAbstract
  • remove C:\Program Files (x86)\RemObjects Software folder
  • uninstall all RemObjects.* dll from GAC
  • also you can remove all RemObjects.* folders from these folders:
    • C:\Windows\assembly\GAC_MSIL
    • C:\Windows\Microsoft.NET\assembly\GAC_MSIL

  • launch VS - it should be launched w/o any warnings

  • install Elements
  • install both Data Abstract

I’ll try thank you


I’ve followed the instructions, removing every occurrence of RemObjects in GAC

But there is still some reference is missing:

These are the new installed in GAC

Is there some other place do look for new missing references?

Thank you.


Check your dxserver project and licenses.licx in it - they shouldn’t contain version

finally you should remove hardcoded dependence to .1495 build.


The file licenses.licx keeps these versions

RemObjects.SDK.Server.MemorySessionManager, RemObjects.SDK.Server, Version=, Culture=neutral, PublicKeyToken=3df3cad1b7aa5098
RemObjects.DataAbstract.Server.ConnectionManager, RemObjects.DataAbstract.Server, Version=, Culture=neutral, PublicKeyToken=3df3cad1b7aa5098
RemObjects.SDK.Server.IpHttpServerChannel, RemObjects.SDK.Server, Version=, Culture=neutral, PublicKeyToken=3df3cad1b7aa5098
RemObjects.DataAbstract.Server.ODataSchemaDispatcher, RemObjects.DataAbstract.Server, Version=, Culture=neutral, PublicKeyToken=3df3cad1b7aa5098
RemObjects.DataAbstract.LocalDataAdapter, RemObjects.DataAbstract.Server

We must replace for the new one or there is a way to not bind to the version?

Is there a way to generate this file dinamically? Or just in the project creation?

Thank you.


replace it with

RemObjects.SDK.Server.MemorySessionManager, RemObjects.SDK.Server
RemObjects.DataAbstract.Server.ConnectionManager, RemObjects.DataAbstract.Server
RemObjects.SDK.Server.IpHttpServerChannel, RemObjects.SDK.Server
RemObjects.DataAbstract.Server.ODataSchemaDispatcher, RemObjects.DataAbstract.Server
RemObjects.DataAbstract.LocalDataAdapter, RemObjects.DataAbstract.Server


It works fine, thank you for the help

1 Like


In a enviroment appeared this error after clean instalation

3>C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\MSBuild\RemObjects Software\Elements\RemObjects.Elements.Echoes.targets(53,3): error E253: Error while generating executable: System.NotSupportedException: System.String
3>   em Mono.Cecil.SignatureWriter.WritePrimitiveValue(Object value)
3>   em Mono.Cecil.SignatureWriter.WriteCustomAttributeValue(TypeReference type, Object value)
3>   em Mono.Cecil.SignatureWriter.WriteCustomAttributeElement(TypeReference type, CustomAttributeArgument argument)
3>   em Mono.Cecil.SignatureWriter.WriteCustomAttributeFixedArgument(TypeReference type, CustomAttributeArgument argument)
3>   em Mono.Cecil.SignatureWriter.WriteCustomAttributeNamedArgument(Byte kind, CustomAttributeNamedArgument named_argument)
3>   em Mono.Cecil.SignatureWriter.WriteCustomAttributeNamedArguments(Byte kind, Collection`1 named_arguments)
3>   em Mono.Cecil.SignatureWriter.WriteICustomAttributeNamedArguments(ICustomAttribute attribute)
3>   em Mono.Cecil.MetadataBuilder.GetCustomAttributeSignature(CustomAttribute attribute)
3>   em Mono.Cecil.MetadataBuilder.AddCustomAttributes(ICustomAttributeProvider owner)
3>   em Mono.Cecil.MetadataBuilder.AddMethod(MethodDefinition method)
3>   em Mono.Cecil.MetadataBuilder.AddMethods(TypeDefinition type)
3>   em Mono.Cecil.MetadataBuilder.AddType(TypeDefinition type)
3>   em Mono.Cecil.MetadataBuilder.AddTypes()
3>   em Mono.Cecil.MetadataBuilder.BuildTypes()
3>   em Mono.Cecil.MetadataBuilder.BuildModule()
3>   em Mono.Cecil.MetadataBuilder.BuildMetadata()
3>   em Mono.Cecil.ModuleWriter.Write(ModuleDefinition module, Disposable`1 stream, WriterParameters parameters)
3>   em Mono.Cecil.ModuleWriter.WriteModule(ModuleDefinition module, Disposable`1 stream, WriterParameters parameters)
3>   em Mono.Cecil.ModuleDefinition.Write(String fileName, WriterParameters parameters)
3>   em E.b(Stream a)
3>Projeto de compilação pronto "dxserver.oxygene" -- FALHA.

What could I do to fix it?

I think is the same error:

We have found this in GAC

Mono.Cecil, Version=, Culture=neutral, PublicKeyToken=50cebf1cceb9d05e, processorArchitecture=MSIL

ro_assemblies.txt (137.5 KB)

Thank you.

This seems to be a separate error, and an actual compiler bug. could I get

(a) the full build log with :“Diagnostic” level? (easiest would be to build the project from the command line: “ebuild dxserver.oxygene --debug

(b) the full project (via PM to support@ or mh@) that shows this error?


I’ve sent a message in private

1 Like

Thanx. I cannot reproduce the problem locally, but I also notice from the log that toner compilers is ancient:

Version (develop) built on bajor, 20220415-141032. Commit e27166a.

can you update to latest and see if the issue persists? We fixed and changed a lot since April.