Error creating strongly typed dataset VS 2017

(Wouter Devos) #1

I try to create a strongly typed dataset in VS 2017 (C# winforms AND C# WPF)

Anyone who had the same problem ? I guess this is the first time. I’m woking with VS 2017 for a week now, and it did work before.
I also re-installed RO/DA and that did not work

This is the error I get

[‎17/‎03/‎2017 11:16]
in de midelco source
Strongly Typed Dataset generator failed:
System.Exception: The component ‘RemObjects.DataAbstract.Designtime.Wizard.WizardView’ does not have a resource identified by the URI ‘/RemObjects.DataAbstract.Designtime;component/wizard/wizardhost/wizardview.xaml’.
at System.Windows.Application.LoadComponent(Object component, Uri resourceLocator)
at RemObjects.DataAbstract.Designtime.Wizard.WizardView.InitializeComponent()
at RemObjects.DataAbstract.Designtime.Wizard.WizardView…ctor(k locator, Int32 owner)
at A.A.Execute(Boolean startedFromContextMenu)
at A.A.Execute(b kind, Boolean startedFromContextMenu)
at A.Q.ExecuteWizard(Boolean startedFromContextMenu)

(Wouter Devos) #2

In VS 2015 with the same components, it works fine.

VS 2015 and VS 2017 are on the same machine.
Tried to remove RO/DA from my computer - reboot - re-install RO/DA
this did not solve the problem.

(antonk) #3


Could you provide more details?

  • Exact DA version installed
  • Exact steps to reproduce the issue (with a testcase project if possible)

Thanks in advance

(Wouter Devos) #4

Hi Anton,

The version was the latest from the website.
I have 2 projects
The main project in winforms works fine in VS 2015 and VS 2017
The project in WPF was working fine in VS 2015 but right click on remotedataadapter and create strongly typed dataset was no longer working in VS 2017 suddenly.
Same solution, same computer, it worked in VS 2015, so I worked in that environment whole day.
On Friday I rebooted, re-installed RO/DA, rebooted again … nothing works

Now, as I want to check again, I can create a strongly typed dataset again ???
I have no idea what happened, but my computer config has not been changed since friday.
I would say it was a friday 13th problem :smile:

My problem is gone for now, maybe someone else is having this too ?

Anyway, thanks for the help


(antonk) #5

I’ll investigate this (because such issues have a bad habit to arise again), yet if is a really stange glitch:

  1. WPF and WinForms projects use the same DE integration code, so if one failed - other had to fail too
  2. Even more - VS 2015 and VS 2017 use the same UI code (that failed) - so again they should both work or both fail

The only explanation I see is that VS 2017 for some reason loaded 2 copies of RemObjects.DataAbstract.Designtime with different version numbers and that caused the resource loading bug.

This could be caused by a coupe of reasons:

  • WPF prject was once built with older version of DA/.NET and there were remnants of these references in the bin and obj folders, so VS loaded frong desingtime assembly
  • There were several copies of the DA extension installed in VS 2017 and they conflicted. Could you check your extensions list in Tools - Extensions and Updates in VS 2017 ?