Error : Reference 'GoApi' could not be resolved for target 'Echoes' (Echoes .NET anycpu)


(Geir Harald Humstad) #1

GoApi is a NuGet-package I updated today. I have also updated Oxygene since the last build, and the project is a Hydra Plugin. What does the message mean?
I also get a design error on the form:
Could not load file or assembly ‘RemObjects.Everwood.Live, Version=4.7.85.785, Culture=neutral, PublicKeyToken=3df3cad1b7aa5098’ or one of its dependencies. The system cannot find the file.

The call stack is:
at RemObjects.Hydra.Internal.ROLicenseProvider.CreateKey(Type aType)
at RemObjects.Hydra.Internal.ROLicenseProvider.GetLicense(LicenseContext context, Type aType, Object anInstance, Boolean aAllowExceptions)
at System.ComponentModel.LicenseManager.ValidateInternalRecursive(LicenseContext context, Type type, Object instance, Boolean allowExceptions, License& license, String& licenseKey)
at System.ComponentModel.LicenseManager.Validate(Type type, Object instance)
at RemObjects.Hydra.VisualPlugin…ctor()


(marc hoffman) #2

It means that it somehow cannot turn that reference into a path to a .dll it can actually use. Can you show me what the reference looks like in your project, and a (detailed-level) rebuild build log output? Also, how was this reference added?

This seems unrelated, I’ll need to have someone from the Hydra team handle this in detail. But it looks like a dll version mismatch. What version of Hydra do you have installed? 6.0? 6.1 beta?


(Geir Harald Humstad) #3

I was able to sort out the reference by removing and then add it again. (I’m used to Delphi so Visual Studio is a bit strange to me.)
On the second issue I ran the installation program of Hydra, and everything was sorted out by doing that. :blush:


(marc hoffman) #4

Ah, glad to hear on one hand, but a shame as id would have liked to end out what went wrong :wink:

It’s strange to everyone ;)/ Have you tried Water, yet?

good!