Errors creating Android Mercury projects in Visual Studio 2019

Visual Studio 2019 16.8.3
Note: in my environment, I have the following workloads installed: ASP.NET and web development, .NET desktop development, Mobile development with .NET

First I tried to create a Mercury for Android List View application:

When I click on the Create button on the next page of the wizard, I get this error:

Then I tried to create just a Android Application:

Clicking on the Create button in this case causes a different error:

Note: Creating an Android Library (Android SDK) project for Mercury worked fine.


Definitely a bug, thanx!

As a workaround, can you trey creating the project in Water? You should be able to then open it in VS fine, too.

Thanks, logged as bugs://85310

Okay, I tried creating both types of projects in Water instead of VS2019. And yes, both projects created fine. Yay!

However, both projects will not build successfully in Water - they both show this error:

E: JDK Folder was not found, is not set up in CooperPaths.xml, or does not exist.

Same error if I then try to load those projects into VS and build from there.

I have zero experience with building Android apps, so feel free to tell me that I am missing something in my setup for that.



Hmm. Do you have Android Studio and there Android SDK installed, as described at

Nope - you are absolutely correct, I need to install that. I was just thinking the same thing, that maybe I was missing a prerequisite. I will give that a go, but I’m sure that’s the issue. Thanks.

1 Like

Yes, the issues was that I had not installed Android Studio and the Android SDK. I am now able to build successfully.




bugs://85310 got closed with status fixed.